Howto: PHP 7.2 & 7.3 on Debian stretch/9 - using phpswitcher 4.0.3

  • That will be great if you provide this patches today.

    Thanks Laurent

    I'll do my best ;) I've just started with specific repository for that purpose:


    ouch.png

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Thanx Nuxwin - at least I added the nxw_* patches... but you're right... I did not change the other patches as long as there were no error....


    /J

  • TheCry


    Sorry for the delay... I'm still working on the new version, refreshing all patches and performing required tests. I covered you use case for PHP 5.6.40:



    /opt/phpswitcher/20190822/php5.6/etc/php/conf.d/modules.ini:


    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • So I do not know what is with me again when I do it as described I get the following error message.



    Code
    1. [ERROR] main: An unexpected error occurred: An error occurred while executing the clean MAKE(1) target for php-7.3.8: /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/Makefile:297: *** missing separator. Schluss.
    2. root@ns314319:/var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler#

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • So I do not know what is with me again when I do it as described I get the following error message.



    Code
    1. [ERROR] main: An unexpected error occurred: An error occurred while executing the clean MAKE(1) target for php-7.3.8: /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/Makefile:297: *** missing separator. Schluss.
    2. root@ns314319:/var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler#

    Please, don't follow that howto. Read the previous posts to understand why.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • "Missing separator" - the syntax in the Makefile (especially the whitespaces at the beginning of the line) is important...


    So I think it's a copy-paste error - it's the line with the skel.


    The first char is a "Tab" and then the "[ -f ext/ext_skel ] && mv ext/ext_skel ext/ext_skel.in" folows....


    But also read the warning of nuxwin... - I hope he'll provide some better patches...


    /Joximu

  • Hi,


    I also started to implement the mentioned solution to be able to install php7.3 - hopefully in a non-intrusive way to allow future i-MSCP and PhpSwitcher upgrades without problems.


    Currently I'm stuck with this error:

    Quote

    The following packages have unmet dependencies:

    libssl-dev : Depends: libssl1.1 (= 1.1.0k-1~deb9u1) but 1.1.1c-1+0~20190710.13+debian9~1.gbp359e02 is to be installed

    [ERROR] main: An unexpected error occurred: An error occurred while installing build dependencies: E: Unable to correct problems, you have held broken packages.


    I'm already running 1.1.1c-1, which was pulled in from packages.sury.org

    Did I already do a mistake previously? Do I need to pin 1.1.0k-1? Will this result in any other issues?


    Thanks for any advice.


    Sven.