Howto: PHP 7.2 & 7.3 on Debian stretch/9 - using phpswitcher 4.0.3

  • I'm already too new. Should I just downgrade?


    Downgrading would result in removal of a whole bunch of packages:

    Edited once, last by major ().

  • major


    Don't do that. Just wait a bit...

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Hey Nuxwin ,


    I'd really prefer to wait for an official upgrade path. I read your recent posts on Twitter regarding PHP7.x tests are now passing. Really appreciate your hard work on this.


    Could you give a rough schedule for the release maybe? I'm currently facing resellers who will leave if they woun't get access to PHP 7.3 soon.

    I know, it's hard to tell, but should I expect it more like two weeks or two months until the next release? :)


    Best regards,

    Sven.

  • I'm a week late in fact due to personal reasons... The new version should have been released last sunday... The new version should be released tomorrow.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Hi Nuxwin ,


    any updates regarding the phpswitcher update? We need support for php 7.2/7.3 around end of october. Do you think this will be ready for Q4 2019?

    We're looking forward to the next updates and thank you for your work with i-mscp.


    Kind regards,

    freedom

  • major

    Will be released in few hours ;)


    progress.png

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • I'm still free, I hope the release comes when I'm not working.

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • If you drive home Nuxwin will delete the new release... :D

    I hope that he does not do that because otherwise not only me but also his other customers because :cursing:8o8o8o8o8o;(


    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)