Posts by major

    Hi Nuxwin ,


    I successfully built 7.2, 7.3 and 7.4 in a testing environment. My system default is 7.1 at the moment. Other php versions are not of any interest to me.

    When building the 7.x versions, I did not run into any of the problems reported by other users, however I have a bunch of tools (like SNMP) installed on all my systems anyway.


    Best regards, Sven.

    Hey Nuxwin ,


    I'd really prefer to wait for an official upgrade path. I read your recent posts on Twitter regarding PHP7.x tests are now passing. Really appreciate your hard work on this.


    Could you give a rough schedule for the release maybe? I'm currently facing resellers who will leave if they woun't get access to PHP 7.3 soon.

    I know, it's hard to tell, but should I expect it more like two weeks or two months until the next release? :)


    Best regards,

    Sven.

    I'm already too new. Should I just downgrade?


    Downgrading would result in removal of a whole bunch of packages:

    Hi,


    I also started to implement the mentioned solution to be able to install php7.3 - hopefully in a non-intrusive way to allow future i-MSCP and PhpSwitcher upgrades without problems.


    Currently I'm stuck with this error:

    Quote

    The following packages have unmet dependencies:

    libssl-dev : Depends: libssl1.1 (= 1.1.0k-1~deb9u1) but 1.1.1c-1+0~20190710.13+debian9~1.gbp359e02 is to be installed

    [ERROR] main: An unexpected error occurred: An error occurred while installing build dependencies: E: Unable to correct problems, you have held broken packages.


    I'm already running 1.1.1c-1, which was pulled in from packages.sury.org

    Did I already do a mistake previously? Do I need to pin 1.1.0k-1? Will this result in any other issues?


    Thanks for any advice.


    Sven.

    Hi,


    I'm also waiting for support of newer PHP versions. Please be aware that PHP 7.1 is no longer actively developed since Dec 1, 2018, and security update support ends on Dec 1st 2019.


    I really try not to do manual modifications like mentioned in the previous post - that's why I bought the plugin - to prevent issues that might occur when updating the plugin later. Could you please upgrade the plugin to be able to use at least PHP 7.2, or could you please confirm that no issues will arise when following the steps in the previous post and upgrading the plugin later on.


    Best regards,

    Sven.