Error in i-MSCP 1.5.3 - maintenance release (testing) on Ubuntu 18.04

  • Hello,


    I've seen the announcement earlier about the testing of 1.5.3 for Ubuntu 18.04 and tried to install it on a fresh VM Ubuntu 18.04 with the latest updates.

    Distro : Ubuntu 18.04.1 LTS \n \l

    Snapshot : https://github.com/i-MSCP/imsc…110e2821f0b16b5ad0.tar.gz

    The server is a fresh install, no apache/php/mysql was installed on it.


    Error while performing step: │

    │ │

    │ Installing distribution files │

    │ │

    │ Error was: │

    │ │

    │ iMSCP::Stepper::_callback: Couldn't stop the imscp_daemon service: Couldn't resolve the imscp_daemon unit: Couldn't resolve the imscp_daemon SysVinit script │

    │ at /root/imscp/engine/PerlLib/iMSCP/Service.pm line 181. │

    │ at /root/imscp/engine/PerlLib/iMSCP/Service.pm line 181. │

    │ at /root/imscp/engine/setup/imscp-setup-methods.pl line 47. │

    │ │

    │ Please have a look at http://i-mscp.net/forum if you need help.


    PS: sorry if it's in the wrong section, i didn't have an option to reply to the original thread.

  • jackstone


    Thank for your report. I'll check this issue.


    Please edit the file /root/imscp/engine/setup/imscp-setup-methods.pl line and replace line 47 by


    Perl
    1. iMSCP::Service->getInstance()->stop( 'imscp_daemon' ) if iMSCP::Service->getInstance()->hasService( 'imscp_daemon' );


    then rerun the installer.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Nuxwin


    Great, that was it, after changing that line it installed perfectly.


    Thank you !!


    P.S. : Any ideea when a stable version will be released ? I have about 20 server which need upgrading from 16.04 to 18.04, and also do you think an upgrade from the old 1.5.3 version running on Ubuntu 16.04 to the current one running on 18.04 is possible and it won't break anything down.


    Many thanks.

  • P.S. : Any ideea when a stable version will be released ? I have about 20 server which need upgrading from 16.04 to 18.04, and also do you think an upgrade from the old 1.5.3 version running on Ubuntu 16.04 to the current one running on 18.04 is possible and it won't break anything down.

    The new version will be released in few days. You'll be able to upgrade to Bionic Beaver, then to latest i-MSCP.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Install to latest snapshot (https://github.com/i-MSCP/imsc…4791efc74f5fb64c19.tar.gz) -> Done



    Install to latest version (https://i-mscp.net/filebase/file/17-phpswitcher/) -> Done


    Script (PhpSwitcher: compile all versions, add APCU and IONCUBE executed and ) -> Done



    my system local



    proxmox 5.3

    sql Maria DB 10.2

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

    Edited once, last by Speddy: proxmox version geändert ().

  • That is the error where i got when i try to install on ubuntu 18.04

    OpEn YouR mINd , OpeN YouR SourcE cOdE

  • my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • have you proxmox?

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)