PhpSwitcher: compile all versions, add APCU and IONCUBE

  • Linux (32 bits) Includes ionCube 24 support tar.gz zip 10.2.4 2018-07-27
    Linux (64 bits) Includes ionCube 24 support tar.gz zip 10.2.4 2018-07-27

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • Linux (32 bits) Includes ionCube 24 support tar.gz zip 10.2.5 2018-09-28 UPDATED
    Linux (64 bits) Includes ionCube 24 support tar.gz zip 10.2.5 2018-09-28 UPDATED

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • OS/Platform Packages Version Release Date
    Linux (32 bits) Includes ionCube 24 support tar.gz zip 10.2.7 2018-11-08 UPDATED
    Linux (64 bits) Includes ionCube 24 support tar.gz zip 10.2.7 2018-11-08 UPDATED






    Beta Loaders for PHP 7.3

    The following are beta ionCube Loaders that can be used with the release candidate (RC) versions of PHP 7.3.0 on Linux and FreeBSD 11. They can run files encoded with the version 10 PHP 7.1 and 7.2 Encoders. As with PHP 7.3.0 RC versions themselves, these loaders should not be used in a production environment.


    OS/Platform Package Version Release Date

    Linux (32 bits) tar.gz 10.3.0-beta 2018-11-13 UPDATED

    Linux (64 bits) tar.gz 10.3.0-beta 2018-11-13 UPDATED

    FreeBSD 11 (32 bits) tar.gz 10.3.0-beta 2018-11-13 UPDATED

    FreeBSD 11 (64 bits) tar.gz 10.3.0-beta 2018-11-13 UPDATED

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • added Ioncube 7.3

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • I improved the script to not add redundant code (50% less lines of code) for each new version:


  • APCU new Version



    5.1.14 - Fixed GH #347: Disable slam defense by default.
    - Fix potential issue with destruction of locks. This does not affect Linux, but might affect Windows and BSD.
    - Use mutex instead of rwlock for shared memory allocator (if pthreads mutex available).
    - Require only read-lock for apcu_cas(), by using atomic compare-and-swap.

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

    Edited once, last by Speddy ().

  • Changelog for APCu

    5.1.15 - Restore apc.serializer=php as the default, as the "default" serializer still/again has issues.
    - Fix possible issues in persistence of arrays with the "default" serializer.
    - Attempt to reduce shared memory fragementation.



    5.1.15 stable 2018-12-07 apcu-5.1.15.tgz (91.8kB) windows-icon.pngDLL [Changelog]

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

    Edited once, last by Speddy ().

  • Added APCu version 5.1.15



    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)