i-MSCP (1.5.x) installation failures on Debian 9.5

  • Hello,


    I try to install i-mscp in Version 1.5.x on an Debian 9.5 PC


    The first error happens when i try to install mysql. The installation crashes with the Info the "mysql/mariadb...." also a new try with the perl imscp-autoinstall -dr fails with the same error.


    After a new installation of Debian (i wanted a clean PC) iI tried to choose mariadb and it works. If the installation process is ready i reboot the PC and oh ... no connection to the Internet... i check with ifconfig and so the LAN-Adapter is away. No LAN only lo is up and running.


    So i tryed es till now 6 times and my PC is being newly installed the7th time today.


    I tryed it with 1.5.1 an there is the same.


    Thank you for helping me :)

  • I try to install i-mscp in Version 1.5.x on an Debian 9.5 PC

    You mean the GIT version from our github repository?

    The first error happens when i try to install mysql. The installation crashes with the Info the "mysql/mariadb...." also a new try with the perl imscp-autoinstall -dr fails with the same error.

    We need the exact error, else, we cannot help...


    After a new installation of Debian (i wanted a clean PC) iI tried to choose mariadb and it works. If the installation process is ready i reboot the PC and oh ... no connection to the Internet... i check with ifconfig and so the LAN-Adapter is away. No LAN only lo is up and running.


    So i tryed es till now 6 times and my PC is being newly installed the7th time today.

    1. Well, first, it is a TRUE debian server installation without any X server or do you try to install i-MSCP on a Debian with a X server (desktop)?
    2. Before installing i-MSCP, what was the content of your /etc/network/interfaces file?

    Please provide us with all relevant information, else, we cannot help.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Nuxwin

    Changed the title of the thread from “Install in Debian 9.5 failed” to “i-MSCP (1.5.x) installation failures on Debian 9.5”.
  • Nuxwin

    Added the Label wait for reply
  • Hello Nuxwin,


    yes i try to install on an Server with X.

    The /etc/network/interfaces is:

    The next time i install the Server without X and try it. But i thinkk i use the GIT-Version in the Future.

    Thank you...

  • TiDschay


    So, there is a problem with the DB schema. I'll check that this evening.


    To be sure:


    You tried on debian Stretch, with i-MSCP 1.5.x and you have chossen MySQL 5.7, right?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif