Following a MySQL upgrade failure (version 5.5 to 5.6) with i-MSCP 1.4.7, upgrade to i-MSCP 1.5.3 is failing

  • Hello,


    Distro: Debian 8 (Jessie)

    I-MSCP Version: 1.4.7

    SQL Server: 5.6 / after failure currently 5.5


    I got a problem with our i-mscp enviroment after trying to update to mysql 5.6. I followed the instruction from https://i-mscp.net/index.php/T…SCP-MySQL-update-5-5-5-6/ to update the mysql version for i-mscp 1.4.7. Everything seems to work, but the process aborted with an unknown error at mysql-community-server. But the mysql server updated successfully to 5.6 and every service was online and ready.


    Since the failure got me and we wanted to upgrade to 1.5.3 anyways, I disabled every i-mscp plugin via the database and started the update for i-mscp 1.5.3. Because of that aborted mysql update, i-mscp didn't realize the mysql 5.6 server, so it uninstalled that package and tried to installed mysql 5.5 again and crashed as expected in this case, because of the information on here: Nach MySQL Update geht nichts mehr.


    Seems like i got the same problem and I'm unable to find the working solution.

    Maybe Nuxwin could give a hint, how can I solve the problem, because he already solved the case for another customer.


    Any ideas would be great. :)


    Thanks for your time.

  • freedom

    • Remove the /etc/imscp/imscpOld.conf file if any
    • Edit the /etc/imscp/imscp.conf file and replace:
      Code
      1. SQL_SERVER = mysql_5.5

      by

      Code
      1. SQL_SERVER = mysql_5.6
    • Rerun the installer from the i-MSCP 1.5.3 version: perl imscp-autoinstall -d

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Nuxwin

    Added the Label question (answered)
  • Nuxwin

    Changed the title of the thread from “After mysql change from 5.5 to 5.6 - i-mscp update to 1.5.3 failed” to “Following a MySQL upgrade failure (version 5.5 to 5.6) with i-MSCP 1.4.7, upgrade to i-MSCP 1.5.3 is failing”.
  • Hi Nuxwin ,


    No /etc/imscp/imscpOld.conf was found and I edited the /etc/imscp/imscp.conf. I changed the SQL_SERVER to mysql_5.6.


    After that I used perl imscp-autoinstall -d again for i-mscp 1.5.3. Seems to be still a conflict with the aborted mysql update before and now i-mscp wants to configure mysql 5.5 and crashed in this case.


    Output from perl imscp-autoinstall -d:



    I think I totally failed because I tried to update to i-mscp 1.5.3 after the mysql update from i-mscp 1.4.7 only works half the way. Would be happy if you can help me to find the problem and got a working i-mscp 1.5.3 with mysql 5.6 again.


    I will send you server access data right now via conversation. Hope we can fix this. :)

  • freedom


    i-MSCP doesn't want install MySQL 5.5 but APT want due to previous failure ( package configuration left in inconsistent state)... Waiting for server access...


    I need in order:

    1. Server IP,
    2. system root user password
    3. MySQL root user password

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • freedom


    Fixed. In order, I've done the following:

    1. I've purged the mysql-server-5.5 and mysql-client-5.5 packages: apt-get purge mysql-server-5.5 mysql-client-5.5
    2. I've rerun the i-MSCP installer (i-MSCP 1.5.3 version) as follows: perl imscp-autoinstall -dr sql, then when asked, I've choosen the MySQL 5.6 version. For the questions related to the SQL root user and passwod, I've answered with the i-MSCP master SQL user.

    Regarding your system


    You should really considere to update your system. There are many package updates available. See the output of the apt-get dist-upgrade -s command. If you do so, don't forget to rerun the i-MSCP installer (from the 1.5.3 version) once the packages update is done.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Nuxwin

    Set the Label from question (answered) to solved through online support