Posts by biologist

    I remember having the same issue as described above. Meanwhile (don't know when exactly) the problem disappeared and seems to be finally gone now. However, tried a lot of stuff but never fount the focus of the problem nor found anything weird in the logs. So all I was able to do was acting symptomatic: Apache was resarted automatically when this problem occured.

    Ich hatte das Problem auch mal und war mir jetzt nicht mehr sicher, wie ich das gefixt hatte. Daher habe ich mal kurz /var/www/imscp/engine/messenger/imscp-arpl-msgr gegen das File gedifft, das im Zip-Archiv von i-mscp 1.5.3 liegt:


    < Data => encode( 'utf8', $val )


    > Data => encode( 'iso8859-1', $val )

    Ergo: Versuche mal das utf8 durch iso8859-1 zu ersetzen und teste dann nochmal.

    Es gibt verschiedene Möglichkeiten, wie man das machen kann. Mit den Einstellmöglichkeiten pro Benutzer habe ich die Erfahrung gemacht, dass es die Benutzer überfordert und sie es deswegen eh nicht nutzen. Habe damals Maia ( dafür benutzt, das ist eine Webgui mit einem angepassten amavisd, in den Spamassassin eingebunden wird. Es wird aber schon seit Jahren nicht mehr benutzt. Also man konnte da verschiedene Sicherheitslevel definieren und die Benutzer konnten Punktegrenzen vergeben, aber das versteht ein normaler Benutzer nicht.

    Was du aber ggf. suchst ist Sieve. Das kann man als Plugin in Dovecot aktivieren. Im Gegenzug gibt es für Roundcube dann zB ein Sieve-Plugin, mit dem Benutzer Regeln definieren können. Sie müssen sich dabei nicht mit der vergleichsweisen kryptischen Sieve-Syntax befassen, sondern können sich die Filter zusammen klicken. In Sieve sieht das dann zB so aus:

    1. require ["body","copy","fileinto","regex"];
    2. # rule:[Spam]
    3. if (header :contains "x-spam-flag" "YES")
    4. {
    5. fileinto "INBOX.Junk";
    6. stop;
    7. }

    Man kann global eine solche Regel definieren (das müssen die Benutzer aber natürlich wissen/wollen) oder halt pro User.

    Hmm, shows a little progress, but stops with


    [ERROR] iMSCP::Stepper::_callback: The following PHP modules are not installed or not enabled: apc, apcu

    [ERROR] autoinstaller::Functions::build: An error occurred while performing build steps

    But, in fact, it is installed:

    I ran "phpenmod apcu" but the result is the same :-(

    BTW: Thnx for your quick answer.

    Did some further tests and as it seems, PHP 7.1 is the problem. I ran "apt remove php7.1*". It produced some warnings and finally the installation process breaked because of imscp complaining, but the number of packages to be installed was > 700 while previously at around 500-something.

    However, as 7.2 is part of 18.04lts, maybe it makes sense to temporarily remove PHP 7.1 and "telling" imscp to use 5.6 instead. After upgrading to 18.04 php 7.2 would be available so I'd tell imscp later to with 7.2 while 7.1 could be provided using phpswitcher. If there's a better solution, please tell me.

    So I tried to change php-Configuration using

    1. imscp-reconfigure -r php -d

    but I finally ran into

    Subsequently I downloaded the current release but it immediately hangs forever at:


    [INFO] Satisfying prerequisites... Please wait.

    So: What is the suggested way to get rid of these dependency problems?

    Hmm, weird. To update Ubuntu, I ran:

    apt install update-manager-core


    However, I've been creating a snapshot before update. Maybe I'm gonna run the update again and try to keep track on what happens (especially) with Apache2.


    This has nothing to do with the PhpSwitcher plugin but yes, in current version of the PhpSwitcher plugin, there is dependencies problems.

    Don't know, if I got you right. Does that mean the current plugin is not compatible with 18.04? But yes, indeed... I forgot 7.1-repository was introduced by imscp directly.

    Here's my listener. As already written: in the very beginning the indention of the last was missing. I added it but unfortunately, this didn't work.

    Thanks for your help and merry xmas!


    Ubuntu 16.04 LTS / iMSCP Build: 20170908 (1.5.1)


    Ubuntu 18.04 LTS / iMSCP Build: 2018120800 (1.5.3)


    In order to test the installation-process of the current i-mscp-version, I cloned by webserver's content into a local VM. After a number of install-steps, the installer stopped because of:

    1. [ERROR] Servers::mta::postfix::postconf: postconf: fatal: file /etc/postfix/ line 48: bad field count

    So I had a closer look on what happened.

    1. spfcheck unix - n n - 0 spawn
    2. user=policyd-spf argv=/usr/sbin/postfix-policyd-spf-perl

    (Second one is line 48).

    Running postconf manually led to the same problem. It turned out that missing whitespaces led to this problem.

    So I looked up where these two lines come from - a postfix listener:

    1. 'spfcheck unix - n n - 0 spawn',
    2. 'user=policyd-spf argv=/usr/sbin/postfix-policyd-spf-perl'

    Obvisously I forgot to intruduce whitespaces in the second line. So I did now but again, postconf complained. Finally, after deleting those two lines from config as well as listener, it worked.

    I'm not sure if I did something wrong or if imscp "forgets" to add the whitespaces I introduced.


    However, I'm having another question:

    I'm using phpswitcher along with two 5.6-versions and one 7.1. It turned out that 5.6 was deactivated because of:


    `/opt/phpswitcher/20170817/php5.6/bin/php-cgi' doesn't looks like a PHP FastCGI binary

    To be honest, I don't know whats wrong with it. So my question is: what could be the missing criteria?


    At last, after upgrading from 16.04 to 18.04, I started the imscp-installer. This didn't work because of

    After running "apt-get install curl" a lot of packages were installed (PHP 7.1 e.g.). But again, the next try led into:


    The following packages have unmet dependencies:

    apache2 : Depends: apache2-utils (= 2.4.29-1ubuntu4.5)

    Depends: apache2-data (= 2.4.29-1ubuntu4.5) but is to be installed

    E: Unable to correct problems, you have held broken packages.

    "apt list --upgradable" showed several packages to be installed, so I did.


    The following packages will be upgraded:

    libgd-dev libgd3 libpcre16-3 libpcre3 libpcre3-dev libpcre32-3 libpcrecpp0v5 libssl1.1 libtidy-dev libtidy5deb1 openssl php-apcu php-apcu-bc php-bcmath php-bz2 php-common php-pear php-soap php7.1 php7.2-bcmath php7.2-bz2

    php7.2-common php7.2-soap

    23 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    Unfortunately next try to start installation led into:


    The following packages have unmet dependencies:

    apache2 : Depends: apache2-data (= 2.4.29-1ubuntu4.5) but is to be installed

    E: Unable to correct problems, you have held broken packages.

    So it turned out, that apache has not been installed because of dependency-problems.

    Finally I ended up with

    This worked.

    Well, but in the end, I don't know where these dependency-problems came from. Is this maybe because of using

    deb xenial main

    deb-src xenial main


    I just mention all that stuff, because phpswitcher introduced this repository.

    I'm sorry to put three things into a single topic, but I'm not sure if they're really related to imscp or jsut because I made something wrong. So I don't wanted to open 3 threads in a row.

    Thanks in advance.

    Im MX-Record steht bei dir, aber das Zertifikat ist ausgestellt auf Sinn?

    Wenn du dich auf mail. verbindest, aber server. im Cert steht, gibts einen Hostname-Missmatch.

    Wenn du diese Warnung nicht willst, dann muss du dich auf den Namen verbinden, der auch im Cert steht. Aber davon ab gibts dann immer noch eine Warnung, weil dein Zertifikat selbst signiert ist. Da brauchst du dich über Warnungen eh nicht wundern...