HowTo: I-MSCP 1.5.3 installation on Debian 10

  • But: I cannot create folder access control, and switching the language is not possible, it stays on "browser detected" (Automatisch (Browsereinstellung)).

    hmm. I don't experience these problems ...

    the language setting could be caused by a browser or cookie (session) issue

    for the mount point problem, please check your imscp database (all tables) for status ok w/ PMA and regenerate all configs afterwards:

  • Thanks for the reply.


    I fixed the mount point by altering document_root in the database, running "perl imscp-reconfigure -r httpd" afterwards. That works for the moment.


    I switched accepted language to english on top in Chrome, so language is also working sort of.


    I created the password manually using .htaccess/.htpasswd.


    I tried to investigate the problem, it seem the error is thrown here:


    /var/www/imscp/gui/public/client/domain_edit.php


    Code
    1. 242 if ($documentRoot !== '/' && !$vfs->exists($documentRoot, VirtualFileSystem::VFS_TYPE_DIR)) {
    2. 243 set_page_message(tr('The new document root must pre-exists inside the /htdocs directory.'), 'error');
    3. 244 return false;
    4. 245 }

    I enabled debug mode to prevent caching, commented the error message assignment and changed the return value to ture, but the error remains.


    So there seems to be broken something in the VirtualFilesystem class in relation to buster.


    I'll chekc deeper into it when I have more time, but for the moment it's good enough to continue my project.

  • tracer

    which PHP version is set as standard?

    I followed the instructions from page 1.

    So PHP 7.0.


    I switched the CLI to 7.4 later as it is required by symfony 5.2/composer, but that shouldn't matter for the GUI, should it?


    Checked the panel, 7.0.33 is still set as default.