Php switcher php 5.6 version.

  • Hy please help.


    How I can settle it on the 5.6 versions the memcache accessory?

    5.3, 5.4, 5.6, 7.0 there are versions above php switcher 5.0.5


    Thnaks.

  • php switcher

    cd /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler



    perl php_compiler.pl --auto-setup 5.6



  • This php.ini?

    Is it necessary to put it into this?

    /opt/phpswitcher/20201214/php5.6/etc/php/php.ini


  • /opt/phpswitcher/20201214/php5.6/etc/php/conf.d/modules.ini


  • apt-get update


    apt-get -y install libmagickwand-dev memcache


    /opt/phpswitcher/20201214/php5.6/bin/pecl install memcache


    echo 'extension = memcache' > /opt/phpswitcher/20201214/php5.6/etc/php/conf.d/memcache.ini

  • apt-get -y install libmagickwand-dev memcache

    Reading package lists... Done

    Building dependency tree

    Reading state information... Done

    E: Unable to locate package memcache

  • memcache shouldnt be installed using apt-get, you should check if it's present as memcache.so in your /opt/...... directory.

    If not install it using pecl.


    Btw, try to use sury repository. It has everything built for you, ready to be installed using apt-get and used !