imscp discontinued?

  • The vuejs problem is that I'm not going to find many people to help me

    I'm a developer and user of i-MSCP and I really like coding in Vue.


    I tend to use Vue on the frontend with a light-weight php slim graphql api on the backend with jwt authentication.

  • Nice to hear that :-) I think Vue.js and Laravel are quite popular and the right choice.


    For authentication Laravel Sanctum (which provides Session and JWT) or Laravel Passport (later for OAuth support) comes to my mind.

  • Just my 2cents...

    Before rewriting it in Vue.js, would it be possible to officially support Debian10 Buster? :)

    The GIT version is working with Buster, but the plugin system didn't finished yet in this version. So if you don't use any plugin then you could use the GIT version.

    OS: Debian Buster

    i-MSCP: GIT 1.5.3-maintenance branch

  • Hi

    I'm with bepe - at least there should be a group of people who are able to support the last release - and create an official release for buster (and devuan beowulf)... including a functional plugin system.

    I know that one person alone cannot handle this - we now have a 1.5.3 build 2018-12-08 since 1.5 years.... - the world was another one when this was released...

    IMHO - it will take too long until the rebuild with another framework has been finished.