Error while upgrade from 1.5.3 to 1.5.3-2018120800

  • Thanks for your help, unfortunately, the same error remains.

    Without further details, we cannot help...

    You should run the reconfiguration script as follows:

    1. perl /var/www/imscp/engine/setup/imscp-reconfigure -dnv

    and provide us the full output.


  • sorry:

    2019-06-30 (3).png


    Now I have to restart the server.

  • Kevin B.

    Your network is not correctly configured and/or the IP set in the i-MSCP database is wrong.

    If you dont figure out, give us access to the server (root access), then we can fix the issue.


  • I just wanted to update to the latest version.

    Have him sent a private message.

  • Kevin B.

    Problem fixed:

    Your primary server IP address is configured manually in the /etc/network/interfaces file, but the configuration mode was set to auto in the i-MSCP database. You MUST not set the auto mode when the IP is manually configured. I've changed the mode to manual and rerun the imscp installer:

    1. # mysql
    2. mysql> use imscp;
    3. mysql> update server_ips set ip_config_mode = 'manual' where ip_id = 1;
    1. # cd /usr/local/src/imscp-1.5.3-2018120800
    2. # perl imscp-autoinstall -dnv

    BTW: I'll review the networking configuration provider to avoid such problem.


  • Thank you very much for your help!

    You're welcome.

    Thread closed.


  • Nuxwin

    Added the Label solved
  • Nuxwin

    Closed the thread.