Error while upgrade from 1.5.3 to 1.5.3-2018120800

  • Hello,

    I have a very bad error when trying to upgrade from IMSCP 1.5.3 to 1.5.3-2018120800


    My system is lock on the step below.

    During this step, I lost my SSH connection and cannot ping my server anymore. I had to reboot it manually.


    Can you help me to fix this?


    OS : Debian Jessie

    Code
    1. Step 7 of 9 │
    2. │ │
    3. │ Processing DB tasks │
    4. │ │
    5. │ Step 1 of 1 │
    6. │ │
    7. │ Processing Modules::ServerIP tasks for: XX.XX.XX.XX (ID 2)
  • Maybe it is related to the fact the record in the table server_ips begins with 2 (and not with 1?)

    Code
    1. MariaDB [imscp]> select * from server_ips;
    2. +-------+-------------+------------+---------+----------------+-----------+
    3. | ip_id | ip_number | ip_netmask | ip_card | ip_config_mode | ip_status |
    4. +-------+-------------+------------+---------+----------------+-----------+
    5. | 2 | xx.xx.xx.xx | 24 | eth0 | auto | ok |
    6. +-------+-------------+------------+---------+----------------+-----------+
    7. 1 row in set (0.00 sec)


    EDIT : I changed the ip_id to 1 and I still have the same issue. Server is completly locked at the same step during the upgrade.

    Edited once, last by darksk ().

  • Finally I removed some unused subdomains and now the installation is working fine.

    I think the script should be corrected to avoid disconnection from SSH.