Posts by Athar

    If I'm not wrong, this is not possible for now.

    "www" entry is static in the DNS zone template file, so this is added for every kind of domains you manage by default through i-MSCP.

    However, I read somewhere that all the DNS thing is being reworked (at least on the todo) so that all DNS entries would be stored into DB and make all those available for modification by end-user.

    In the meantime, maybe some kind of listener file could be use, but as this is only for one domain, honestly, I don't know how to handle that case.

    Hey Nuxwin , me again :D

    I tried to install the DebugBar without success on release 1.5.3-2018120800

    On the plugin page, it's marked "Version compatible with i-MSCP Serie ≥ 1.5.x (version ≥ 1.5.2)"

    but, in the info.php of the plugin :

    'require_api' => '1.5.1'

    But, if I'm not wrong, this plugin API will be at that version for the upcoming release ?

    This is my imscp.conf, maybe it's wrong, or not :D :

    Hi Nuxwin and HB to you (don't buy a car :D ),

    I'm faced to an issue, which I'm unsure why it happen.

    Steps to reproduce :

    - Get into any customers

    - Create a subdomain

    - In LetsEncrypt, request a certificate for this newly created subdomain (after a few minutes for DNS replication)

    - Go back to the subdomain, SSL Management then enable HSTS

    There, I get :

    - An unexpected error occur.

    - An email with this content :

    As you can see, I can't go further, I don't even get the SQL query :/

    For the test, I did create another subdomain for which I have a Comodo cert.

    Did add the certificate to that subdomain, then after, enable HSTS, it work.

    There might be something wrong between Letsencrypt plugin and subdomain.

    LetsEncrypt on a base domain is working just fine for HSTS, only subdomain seems impacted.

    What can I do to troubleshot this error ?

    Versions :

    Debian 9.8 up-to-date

    I--MSCP 1.5.3-2018120800

    LetsEncrypt : 3.5.0

    PHP Fcgi

    Hummm, really odd so.

    When I did the upgrade from 1.3.1 to 1.3.16 (then 1.4.7 and finally, 1.5.3), root user got always deleted (don't ask me why, I never check that).

    Most of the time, I did recreate the root user on the SQL server, but as far as I remember, each time I did an upgrade, it get wiped-out.

    Like I told you in private, I'm going to fully reinstall my server, maybe something is wrong on it, I really don't know, but if you tell me it's not deleted by the setup, well, must be my server and in that case, forget this message :D

    Hi Nuxwin ,

    I got this exact same issue as described there : IMSCP 1.4.0 backup error

    I did the upgrade from 1.3.1 version to latest, and during this process, we get ride of the root MySQL user (get deleted and everything else, which is fine for me, root bring so much risks).

    After that, all i-mscp process using SQL connection should pass through imscp_user (right ?), but as some may have a "/root/.my.cnf" file with root credential, all new SQL backup will fail :'(

    I was wondering if checking that the file exist on the system, if we should not "delete" (=> brutal) or "rename" (=> safer) it during any imscp (re)configuration process ?


    I'll do some kind of "Nuxwin" answer : If you don't know how the server work, we will not teach you that.

    On other hand, I'll just say that SSL/TLS is enabled IF you have add a certificate for services.

    - For IMAP, when SSL/TLS is enabled, you should use port 993

    - For SMTP, you use the "encrypted" port with... no encryption ?

    So, first, check your installation and you should be fine after, find if you enabled SSL or not would be a good place to start.

    i-MSCP is just a piece of software that help managing your server, but it use standard (postfix, courier, dovecot, etc...), so if you don't have the sufficient knowledge for this, I'm sorry to tell you that but, find someone who knows about those things (or pay Nuxwin , see his profile for his prices)

    Hi Sagi,

    Well, I'll just guess that your version is WAY TOO OLD.

    PHP Switcher v2.2.2 - released on May 13th 2016

    Latest version : v4.0.3 - released on Nov 10th 2017

    So, unless you do not purchase it and grab this old version in a way we will not talk there... your only option will be the purchase and upgrade on your server.

    Purchase are made there :

    PS : Tested on my server, when PHP support is removed, the option is too.

    Hi Nuxwin ,

    I would have loved to not bother you, but... yeah, don't know what's going on there.

    I've got the same issue stated there : Error Compiling PHP Versions for PHP Switcher

    I did apply the "downgrade" package, it did work (for the downgrade) but... after I try the compile again, it fail, take some more time to get into the error and give a bunch of text, but the error remain :/

    Debian : 8.11

    iMSCP : Latest (1.5.3-2018120800)

    PHPSwitcher : 4.0.3

    Command run : perl --auto-setup --skip-builddeps 5.6 7.0 7.1

    Solutions applied :

    - this PhpSwitcher plugin (4.0.3) - Build dependency problem on Debian Jessie

    - and this Error Compiling PHP Versions for PHP Switcher

    I keep searching on my end, but maybe you already have the solution :)


    The error log :

    The installed version of both packages (downgraded):

    EDIT : Possible fix (PHP 5.6.32, 7.0.25 and PHP 7.1.11), please confirm this way Nuxwin :) :

    For this error only.


    /usr/bin/ld.bfd.real: /usr/lib/x86_64-linux-gnu/libc-client.a(osdep.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC

    /usr/lib/x86_64-linux-gnu/libc-client.a: error adding symbols: Bad value

    Fix :


    rm /usr/lib/x86_64-linux-gnu/libc-client.a

    ln -s /usr/lib/ /usr/lib/x86_64-linux-gnu/libc-client.a

    Fix worked for me at least, ouf :


    [DONE] The install MAKE(1) target has been successfully executed for php-5.6.32

    [DONE] PHP versions scheduled for addition: 5.6

    [DONE] PHP versions scheduled for update: 7.0, 7.1

    Hi all,

    A few months back, I open a ER on the Bug Tracker, but want to get some return on it :

    In short, I've some websites that didn't like UTF8 encoding (and can't convert them), so need to set the ISO-8859-15.
    Some times ago, it was set at Apache level, but now, need to be set at PHP level (seems to override the value).

    So, just to know if that can be implemented at some point in the future, or if I need to make a note on my procedures while updating :)