• Hi,

    for me this plugin does not work. :(

    I have followed the tutorial to install the plugin, but when i call the url created, the page showed is blank.

    This work only when i call https//my_domain/cgi-bin/mailman/admin/mailing_list_created and, also with this url, works correctly only with the mailman mailing list. Using the others mailing lists created, the urls in admin page it's incorrect. It links, eg, to https://my_domain/admin/mailing_list_created/members that show i-MSCP Error 404

    My i-MSCP configuration:

    System: Ubuntu 14.04 (trusty tahr)
    i-MSCP Git 1.1.xBuild: 20140915
    Server implementation: Apache/2.4.7 with php5-fpm 5.5.9 , dovecot 2.2.9

    Thank you very much

  • For me http://lists.domain.tld/admin/dev/members where dev is the created mailing list, works fine. But if I delete a list, the url for other mailing list is not longer reachable.

    I'll fix soon.


  • Hi together,

    I discovered last friday that my mailing list are not working at the moment. When I send a mail to one of my lists I get the error message "Recipient address rejected: User unknown in virtual mailbox table;"

    So I checked the configuration of Postfix and discovered that the files transport and mailboxes in /etc/postfix/imscp doesn't have any Mailman specific entrys. So Postfix doesn't know to handle mails for mailman.

    I tried to disable and enable to plugin. but with no success. I also upgraded from I-MSCP 1.1.16 to 1.1.18 today with no success also.

    So someone has an idea whats the problem is and how I can resolve it?

  • I ran into the same problem today.
    Seems there is a trigger / listener missing which creates the transport and mailboxes entries when rebuilding the postfix configuration.

    I've added a new list temporarily - copied and corrected the entries - then removed the new list.
    The files i've edited were /etc/imscp/postfix/working/transports and /etc/imscp/postfix/working/mailboxes - so that my changes are written and hashed to the right places.

    Think that that could be easily fixed ;)

  • @rurcoasteagle

    Yes, entries are not readded on update... It"s a know issue which will be adressed in time (no due date)


  • I recently upgraded to 1.2.5 resulting in an unuable mailman plugin. Reinstalling says it's not compatible with my version of i-MSCP, adding the api_version to the info.php results in errors during install in (same errors after upgrading to 1.2.* after installing the plugin in 1.1.*).

  • Mailman is still not supported, otherwise we had increased the required_api version in git repository...

  • Will there soon be an update for 1.2.x ? Otherwise I install it manually on the domain where it is used .Is that a lot of work Mailman adjust for the Plugin Manager ?



    @Athar thx

    Edited once, last by BaRt ().