Modules::Domain::restore: bzcat: Can't open input file testing_db_live: No such file or directory.

  • Hi all,

    When I run a restore on one of my domains I get this error "Modules::Domain::restore: bzcat: Can't open input file testing_db_live: No such file or directory." in my domains table in domain_status, I have two other servers where it works fine.

    Any tips on how I can quickly get to the bottom of it would be appreciated.

    Running 1.1.5 build 20140327 on Ubuntu 12.04 LTS x64, the file testing_db_live.sql.bz2 exists and was able to be extracted manually with bunzip2 command. It did not look corrupted.

  • Hello ;

    The database testing_db_live dump is surely missing from your backup. As I'm thinking, this can occur if you created the database after the backup. This should be considered as a bug because the restore feature should simply ingnore such a case... Must be confirmed and fixed as well. Can you open a ticket with that thread in reference?


  • Hi Nuxwin,

    This definitely is not the case. The database file is there and can be read (extracted and edited etc).

    I set up a fresh 1.1.5 install on ubuntu 12.04 LTS, created a domain and a database, ran "perl ./imscp-backup-all" then ran the restore from the admin interface and got the same error. This was from a another hosting provider in another country. I am wondering if these backups are broken for everyone?

    Not really sure what to put in a bug report, fresh install backups wont restore. Can someone try their restore on a 1.1.5 install?

    Thanks for your time!

  • I need the logs...


  • Ok there is one Log /var/log/imscp/ and the content is:

    [Thu May 8 09:14:48 2014] [error] Modules::Domain::restore: bzcat: Can't open input file lub_02cms: No such file or directory.

    What other log do you need? I could find no other log with any error like this.

    I-MSCP 1.5.3 - Debian 9 Stretch

  • Hello ;

    I'll process some test today with some fixtures. Be patient.



  • Hey guys, sorry I have been busy and hadn't responded. I was also unsure which logs you needed and planned to set up a VM for you to access which demonstrated the bug and supplied logs.

    I have not found any other log with related information. If you need access to a VM with this issue just let me know and I'll get that set up (you could send a public key). I suspect the error *could* relate to the file extension, as in my .bz2 the file inside ends in .sql, and neither is reflected by the error message.

    Apologies for not having all the information you need. Usually I know where to look. I am sure you are busy people and your time and effort is appreciated.