Latest MariaDB repo data seems to be incompatible with Debian 9

  • Hi all,

    first of all, I am using the latest version of I-MSCP and Debian 9 (9.9). I set up I-MSCP from a clean Debian install (9.7). During I-MSCP setup I have chosen to use MariaDB 10.2:

    However, since about a month, MariaDB updates are not installed due to incompatibility (see attached screenshot from the console):


    I have not altered any apt sources manually. The one currently in use for MariaDB comes from the I-MSCP installation:

    1. deb stretch main
    2. deb-src stretch main

    Strech is the right distro name for version 9. I have googled about the library and for some reason the new requested version only runs with Debian 10. How is it possible that a repo built against Debian 9 requests Debian 10 dependencies? Aptitude offers some solutions. As the packages are part of I-MSCP I do not know what to do. Could you help me solve this conflict, i.e. update MariaDB without destroying I-MSCP?

    Thanks :-)

  • Good morning,

    Please show us the APT preferences files from your /etc/apt/preferences.d directory and also the content of any file in the /etc/apt/sources.list.d directory.

    If you cannot figure out alone, give us access to your server.


  • Hi Nuxwin,

    sorry for the late reply, as I had no access to my server. Here is the answer:


    And the sources.d files:


    2. # You may comment out this entry, but any other modifications may be lost.
    3. deb stable main


    1. deb stretch nginx
    2. deb-src stretch nginx

    Thanks again!

  • Hello together,

    is there any known incompatibility with I-MSCP, Debian Stretch (9.11) and MariaDB 10.2? We're currently using MariaDB 10.1.41 from the first installation of I-MSCP on our new server. Now we would like to switch to MariaDB 10.2, using the autoinstaller, because it's a software requirement for one of our web services. I found this thread and a lot of information regarding i-mscp is compatible with MariaDB 10.2, but I would like to make sure there's no surprise waiting for me.

    So my questions would be:

    • Is this a real bug regarding debian stretch and i-mscp 10.2 or is this a local problem? Unfortunately there was no update since november 3rd.
    • I guess the switch would be going with the autoinstaller using perl imscp-autoinstall -dr sql. Is this correct?

    Thank you for any additional information.

  • Well, in effect there have been some changes in MariaDB repo since last year. You have to change a couple of things in order to upgrade to MariaDB 10.2 from MariaDB 10.1 on Debian Stretch.

    1. Before proceding, make sure you have your MariaDB root password

    2. Remove the package pinning for libmariadbclient18 from /etc/apt/preferences.d/imscp

    3. cd to your imscp setup directory: /usr/local/src/imscp-1.5.3-2018120800

    4. Edit autoinstaller/Packages/debian-stretch.xml and change in the section "mariadb_10.2" -> <package>libmariadbclient18</package> from the package pin

    Then you should be able to run perl imscp-autoinstall -dr sql

    Edit: Step 2 corrected from libmysqlclient18 to libmariadbclient18

    Edited 2 times, last by kess ().

  • I love you.


  • Hi kess and Nuxwin,

    I checked the files from your instructions and did the following changes:

    I can confirm, your instructions work as expected and the problem from the first post seems to be related. I have now MariaDB 10.2.29 and no pending updates from apt update. Thank you very much.

    PS: In the instructions above, you used libmysqlclient18 instead of libmariadbclient18, thats why I was confused first. But after I saw the commit on GitHub I understood your instructions. Thank you both!

    Edited once, last by freedom: Updated answer ().