PhpSwitcher 5.0.3 Problem

  • Hello guys,

    since some days I've successfully installed the last version of PhpSwitcher. It works, everything is ok except when:

    - I run apt upgrade

    - I run apt install xxx

    - I run apt remove xxx

    Every time I fire one of the listed actions, in order to have the sites working again I must execute:

    1. /var/www/imscp/engine/imscp-rqst-mngr -v

    When launching the Request Manager, the configuration files inside the pool.d directories are regenerated and the fpm services restarted.

    Before launching the Request Manager, in every pool.d directory the only present file il www.conf

    The system:

    - Debian 9 x64, i-MSCP 1.5.3-2018120800, Dovecot, php-fpm (7.0 as default), proftpd, MariaDB 10.1

    - Plugins: ClamAV, LetsENcrypt, Mailgraph, Monitorix, OpenDKIM, PhpSwitcher, PostScreen, RoundcubePlugins, ServerDefaultPage, SpamAssassin, WHMCS (all latest versions)

    If you need any further informations, please feel free to ask.

    Thank you,

    bye Kess

  • kess

    That bug should have been fixed in 5.0.3... Seem not. It is caused by the dpkg listener file (provided by the PhpSwitcher plugin) which is responsible to reconfigure/restart PHP versions (packaged) when those are being updated. I'll check the behavior again because the pool configuration file shouldn't be removed in such case.


  • Just a little follow up about this problem.

    The command

    1. /var/www/imscp/engine/imscp-rqst-mngr -v

    just regenerates the pool.d conf files for the sites that aren't using the default system php version.

    In order to regenerate the default php version site's conf files, I had to switch to another version and then back to the default (for every single site) through Web UI.

  • Hi,

    same problem here. After last apt-get upgrade all default pool.d conf file are disappeared.

    Is there any way to force regeneration? I've some hundred sites


    Temporarily I have workarounded with

    perl /var/www/imscp/engine/setup/imscp-reconfigure -danv


    Edited once, last by itcm ().

  • Nuxwin

    Added the Label patched
  • Nuxwin

    Closed the thread.