clamav-milter issues after debian update

  • - IMSCP: 1.5.3 (latest)

    - Distribution: Debian 9

    - Proftpd

    - PHP FPM

    - MariaDB 10.1

    - Dovecot

    - Roundcube

    - Web2FTP

    - Plugins:

    PMA Captcha, RoundCubePlugins, SpamAssassin , LetsEncrypt, PHPswitcher, ClamAV



    after a debian update (incl. clamav) and reboot today, the clamav-milter does not seem to start properly. I started the clamav daemon manually after the system reboot, seems to be running but somewhere it seems that something has changed in the start configurations.


  • fulltilt

    Changed the title of the thread from “clamav issue after update” to “clamav-milter issues after debian update”.
  • Hi fulltilt ,


    I just updated my Debian Stretch server and have the same problem with clamav after the update finished.

    Were you able to solve the problem on your server?


    Unfortunately, the clamav readme - from the no longer supported plugin - got removed on github, so I would like to know if someone was able to fix this. Seems to be a compability problem with the newest clamav update and the plugin configuration.


    Kind regards.

  • Uh wait.^^

    You guys updated i-MSCP too and used the clamav plugin till that point? Or only OS updates?

    If the first, its most likely not compatible anymore or caused somewhat malfuctions with i-MSCP due the fact that its not updated anymore (for free).

    Have a nice day. :)

  • I have updated 10 systems (OS update) 9 of those included a kernel update and one newer system without a kernel update. For the system w/o kernel update, a dialog window appeared and asked should the existing clamav config overwriten yes / no ... for all the other systems, no dialog window was displayed.

    I guess some startup parameters have changed, after a manual "service camav-milter restart" clamav seems to be working, but I have not tested a system reboot yet.

    Edited 2 times, last by fulltilt ().

  • Hi again,


    DrCarsonBeckett : We did not change the config ourselves. The clamav package got updated on debians side and therefore it got updated with an apt-get upgrade (or apt upgrade). And as fulltilt already said, on some systems - an this should be the usual case - the system detects your config and asks if you want to use the new version or your currently using version of the configuration. Additional, you have the option to show the difference and check for yourself.


    But this was not the case in some updates from fulltilt and it was not the case in my update. In these updates the question never got asked and the config is overridden by the clamav package itself. Reinstall from the clamav plugin doesn't solve this and as written above, the latest clamav update seems to be not fully compatible with the latest plugin version.


    I can confirm that it's somewhat still working, but from time to time the error will be shown in the log.


    So the question would be:


    Nuxwin What is the correct way to handle this, until the new clamav plugin, which will be not free anymore, will be released? Should we stay in this situation until then, disable the clamav plugin, or is there any fix for the moment? Unfortunately the clamav readme from the i-mscp plugin is removed, therefore I wasn't able to check and fix the config change myself.


    I still do not understand why the package update did not ask for the config change. For instance: The last update asked for exact the same case, when we updated e.g. the telegraf package. And since you usually have the option: Check the difference between the two and decide which config to use, you can protect yourself from any problems and add new configuration parts for yourself later.


    The weird thing is, that the first error, which also appeared in the mail.err log file, is not there anymore so clamav seems to work for the moment.

  • Ah, then I misunderstood it. Sorry.

    You can try to delete the plugin (fully) and remove every left over file from it manually via ssh. After that try to reinstall it.

    If you want to test that, make sure to save the configs and so on.

    Have a nice day. :)

  • What is the correct way to handle this, until the new clamav plugin, which will be not free anymore, will be released? Should we stay in this situation until then, disable the clamav plugin, or is there any fix for the moment? Unfortunately the clamav readme from the i-mscp plugin is removed, therefore I wasn't able to check and fix the config change myself.

    The README.md file is part of the plugin so you should have access to it under the /var/www/imscp/gui/plugins/ClamAV directory.


    After restarting the clamav-daemon, and the clamav-milter filter, what's the content of the /run/clamav directory, and the /var/spool/postfix/clamav directory ?


    Also please, post the content of your /etc/clamav/clamd.conf file, and the content of your /etc/clamav/clamav-milter.conf file. I'm pretty sure that your milter configuration file is wrong but...


    BTW: Don't forget to surround your copy-past with bbcode tags.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206