iMSCP behind a firewall

  • Hi,


    first of all please excuse the stupid question, but I just can't get any further at the moment.


    I have an iMSCP server behind a PFSense.

    The forwarding itself works very well.


    The problem is that I have different domains on my iMSCP instance. However, if I enter these domains via the Webgui, I only get to one page again and again.


    So for example I have mgross.org and mgw94.de.

    Both sites have different website contents based on iMSCP - but they all continue to work on mgross.org.


    Somebody an idea? :angel:


    Regards

    Michael


    Attached the forwarding rules


    2019-06-24 16_41_57-Window.png

  • Good evening,


    For both sites please, show us the content of the Apache2 vhost (http and ssl versions) files. Don't forget to surround your copy-paste with bbcode tags.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • So you do mean that every page directs you to the contact of mgross.org?

    If yes, was it like this from the very beginning oder did you change something?

    Or what did you mean with "they all continue to work on mgross.org"?

    Did you check the vhost files and log files?


    Edit: Too late. :-/

    . :)

  • Hi,


    thank you very much for your reply.

    Iceman : This is correct - every page redirects to mgross.org - the problem was still from the beginning, because I have set up the environment yesterday evening.



    Unfortunately it is not possible to edit the font in "Code"-Section :(


    I have now set up a 1:1 NAT on the firewall so that everything is passed to the web server - but unfortunately this also produces the same error.


    Regards

    Michael

  • MiGro94


    As I can see, you didn't posted any SSL vhost for the mgw94.de site. Default behavior for Apache when you are asking for inexistent site (here the mgw94.de SSL version), is to serve the first vhost found. So here, because there is no SSL vhost file for the mgw94.de site, Apache serve the SSL version of the mgross.org site. Regarding the redirection, this can be due to the HSTS feature which, I think, is enabled for the mgross.org SSL site.


    If you do not want that behavior, you need to install the ServerDefaultPage i-MSCP plugin, or enable SSL for the mgw94.de site.


    BTW: Because the browser cache HSTS redirects, you'll have to flush them after enabling SSL for the mgw94.de site, else, you'll be still redirected to the mgross.org ssl site...

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • ** Now the monkey smilie is missing who puts his hands in front of his eyes. **


    Thank you very much for assistance.

    I wonder why I didn't notice it myself. :rolleyes:

  • ** Now the monkey smilie is missing who puts his hands in front of his eyes. **


    Thank you very much for assistance.

    I wonder why I didn't notice it myself. :rolleyes:

    You're welcome ;)

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Nuxwin

    Added the Label question (answered)
  • ...


    Edit: Too late. :-/

    Sorry (CHUCKLE) 8o

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Hahaha. Thought about what he meant, removed a part and then re-added it. Took too long. :D

    Btw, just noticed now that the serve default page is (does) way more than I expected it too be. :blush:

    . :)