i-MSCP 1.5.3 - libssl-dev package - Unable to correct problems, you have held broken packages

  • imSCP 1.5.3

    Debian 9

    PHP 7.1 fpm

    LetsEncrypt Plugin 3.5.0

    I can no longer install LetsEncrypt Plugin

    1. Plugin::LetsEncrypt::enable: E: Unable to correct problems, you have held broken packages. at /var/www/imscp/gui/plugins/LetsEncrypt/backend/LetsEncrypt.pm line 266.

    after re-run imscp updater I get following:

    1. The following packages have unmet dependencies:
    2. libssl-dev : Depends: libssl1.1 (= 1.1.0f-3+deb9u2) but 1.1.1-2+0~20181105132527.5+stretch~1.gbp90eb86 is to be installed

    1. libssl-dev=1.1.1-2+0~20181105132527.5+stretch~1.gbp90eb86

    I was able to install the package above, but the imscp installer/ updater does not accept the package

    when libssl1.1 was updated libssl-dev gets removed, seems to be a global imscp package sources problem ...

    Edited once, last by fulltilt ().

  • fulltilt

    Yes ;) In current i-MSCP version, there is an uwanted APT pinning on the libssl-dev package, as on the openssl package. You can fix the problem by editing the /etc/apt/preferences.d/imscp file, removing the following stanza:

    1. Package: openssl libssl-dev
    2. Pin: release o=Debian,n=stretch
    3. Pin-Priority: 1002

    This APT pinning is added by the i-MSCP installer, through distribution packages file. For instance, the autoinstaller/Packages/debian-stretch.xml distribution packages file for Debian Stretch inside the i-MSCP distribution archive comes with the following definition:

    1. <ssl
    2. pinning_package="openssl libssl-dev"
    3. pinning_pin="release o=Debian,n=stretch"
    4. pinning_pin_priority="1002"
    5. >
    6. <package>libssl-dev</package>
    7. <package>openssl</package>
    8. </ssl>

    If you want reconfigure or process a new i-MSCP installation (from distribution archive), you should first change the above statement by:

    1. <ssl>
    2. <package>libssl-dev</package>
    3. <package>openssl</package>
    4. </ssl>

    Ref: https://github.com/i-MSCP/imsc…s/debian-stretch.xml#L375

    This issue will be fixed in next release.


  • Nuxwin

    Added the Label to be fixed
  • Nuxwin

    Changed the title of the thread from “LetsEncrypt Install Error” to “i-MSCP 1.5.3 - libssl-dev package - Unable to correct problems, you have held broken packages”.
  • fulltilt

    Could you please open an issue on our bug tracker? It is more easy for us to track and address issues through our bug tracker?

    Thanks you.


  • Great, Thank you for the quick solution!

  • note: if libssl-dev was removed during a previous OS update you should re-install the package ;-)

  • Nuxwin

    Closed the thread.