Couldn't compile PHP 7.1.14

  • Hallo,


    perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl --auto-setup --force-last 7.1


    I become this error.

    Code
    1. Applying patch 0037-php-5.4.9-fixheader.patch
    2. patching file configure.in
    3. Hunk #1 FAILED at 1287.
    4. Hunk #2 succeeded at 1299 (offset 1 line).
    5. 1 out of 2 hunks FAILED -- rejects in file configure.in
    6. Patch 0037-php-5.4.9-fixheader.patch does not apply (enforce with -f)
    7. /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/Makefile:286: recipe for target 'patch-stamp' failed
    8. [ERROR] main: An unexpected error occurred: An error occurred while executing the install MAKE(1) target for php-7.1.14: make: *** [patch-stamp] Error 1


    How can I solve this error. ?(


    Kind regards
    Viktor


    - Distribution: Debian | Release: 8.9 | Codename: jessie
    - i-MSCP Version: i-MSCP 1.4.5 | Build: 20170613 | Codename: Zimmer
    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 1.2.0), PanelRedirect (v 1.2.0) & SpamAssassin (v 2.0.1)
    - LetsEncrypt (v 3.3.0), PhpSwitcher (v 4.0.3), RoundcubePlugins (v 2.0.1)

    - Distribution: Debian | Release: 8.10 | Codename: jessie

    - i-MSCP Version: i-MSCP 1.5.3 | Build: 20180516 | Codename: Ennio Morricone

    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), PanelRedirect (v 1.2.0) & SpamAssassin (v 2.0.1)

    - LetsEncrypt (v 3.5.0), PhpSwitcher (v 4.0.3), RoundcubePlugins (v 2.0.2)

  • @Viktor



    How can I solve this error.

    You cannot fix that error yourself, unless you have sufficient knownlege for updating patches... You must wait the next PhpSwitcher plugin version. For now, use last PHP version as supported by the compiler (don't use the --force-last flag).

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • @Viktor



    You cannot fix that error yourself, unless you have sufficient knownlege for updating patches... You must wait the next PhpSwitcher plugin version. For now, use last PHP version as supported by the compiler (don't use the --force-last flag).

    Hallo Nuxwin,



    tanks for the support.


    I must call without "--force-last".


    I will test it.


    Thanks
    Viktor

    - Distribution: Debian | Release: 8.10 | Codename: jessie

    - i-MSCP Version: i-MSCP 1.5.3 | Build: 20180516 | Codename: Ennio Morricone

    - Plugins installed: ClamAV (v. 1.3.0), Mailgraph (v 1.1.1), OpenDKIM (v 2.0.0), PanelRedirect (v 1.2.0) & SpamAssassin (v 2.0.1)

    - LetsEncrypt (v 3.5.0), PhpSwitcher (v 4.0.3), RoundcubePlugins (v 2.0.2)