Multiple plugin failure

  • I have upgraded my vserver to Debian 9 (stretch) with a complete fresh install. On the previous Debian version, all imscp services and plugins have been functioning flawlessly. imspc has been upgraded to 1.5.3. Now a number of plugins are not working as they should:


    - letsencrypt (3.3.0): there are no buttons for letsencrypt anymore, neither in the admin nor in any customer interface. The certificates exist, but some are close to expiration and I can't renew them.


    - RoundcubePlugins (2.0.2): the Sieve filters are not functional, despite having them activated in /var/www/imscp/gui/plugins/RoundcubePlugins/config.php ('managesieve_plugin' => 'yes',)



    - OpenDKIM (2.0.0): external DNS server (inwx.de), I have tried the key-entries both with and without quotes. Mail-tester reports "message not signed with DKIM".



    Given that 3 plugins are failing, I am suspecting an issue with the plugin-architecture as such, but I have no clue where to check this. What I have tried so far without any improvement:
    - deactivated and reactivated all plugins
    - reconfigure imscp (perl /var/www/imscp/engine/setup/imscp-reconfigure -danv)
    - reboot the vserver



    Other installed plugins: Mailman (2.0.4), PhpSwitcher (4.0.3), SpamAssassin (2.0.1)



    I would appreciate some help on this and am ready to provide logs, once I know which ones are required. Many Thanks in advance!
    Chris

  • I have upgraded my vserver to Debian 9 (stretch) with a complete fresh install. On the previous Debian version, all imscp services and plugins have been functioning flawlessly. imspc has been upgraded to 1.5.3. Now a number of plugins are not working as they should:

    Previous debian version?
    Previous i-MSCP version?



    - letsencrypt (3.3.0): there are no buttons for letsencrypt anymore, neither in the admin nor in any customer interface. The certificates exist, but some are close to expiration and I can't renew them.

    No access to Let's Encrypt plugin interface meant that the plugin is not enabled. What the plugin management interface say for that plugin?



    - RoundcubePlugins (2.0.2): the Sieve filters are not functional, despite having them activated in /var/www/imscp/gui/plugins/RoundcubePlugins/config.php ('managesieve_plugin' => 'yes',)

    Is sieve installled on the server?



    - OpenDKIM (2.0.0): external DNS server (inwx.de), I have tried the key-entries both with and without quotes. Mail-tester reports "message not signed with DKIM".

    Is the milter configuration correctly inserted in the postfix main.cf?


    Best would be to give us access to the server for investigation.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • @technotravel


    Can you send me the admin password for the control panel access?
    Private convertation is available at the top. Else, send me that data via email: l.declercq@nuxwin.com


    I'll first take a coffee ;)

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Sent - merci d'avance :-)


    P.S.: take your time, no hurry ;-)

    I'll check the server in next minutes. Please in the meatime, don't do anything on it.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • @technotravel

    • LetsEncrypt: The plugin was not activated and many SSL certificates were in inconsistent state. I've triggered renewal of all of them. I've also foced rebuild of VENV (let's encrypt virtual environment)
    • OpenDKIM: Plugin was not activated and the opendkim service was not running due to configuration error.
    • RoundcubePlugins: The plugin was disabled. I had to reactivate it and for and update manually.

    There are still other plugins (Mailman, PhpSwitcher, SpamAssassin) which are currently disabled. You don't targeted them in your previous post so, I've done nothing for them.


    Please now check:

    • Let's Encrypt should be OK
    • OpenDKIM entries should be OK
    • Sieve should be OK

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Thank you!


    It's strange - to me all plugins showed as activated, checked it just before I posted.


    letsencypt and Sieve work now. OpenDKIM not at first try, but I probably have to control / re-enter the keys again. Will revert when done.


    Would you mind telling me what was the configuration error with OpenDKIM?


    Thanks again!
    Chris

  • @technotravel


    You did updated to Debian stretch so I presume that conffile was not updated correctly. To solve the problem, I've simply purged the opendkim package, reinstalled it, checked that the service was running. Then, I've forced update of the OpenDKIM plugin by manually setting its status to toupdate in the database. Once done, I've run: perl /var/www/imscp/engine/imscp-rqst-mngr -v

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif