Always add php ioncube to domain automatically

  • What is the name of the file when you update a new domain or imscp does not override the php file because I have here a customer who always needs an ioncube and this is always overwritten with the update or is not present when a new domain arises.

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • I use php-fpm and I never lose my ioncube configuration even during i-MSCP upgrade.
    When I create a new domain for a new customer he receives ioncube exactly like all the Others

  • How do you have your setting for php because I have the setting per page since I do not get it.

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • For version 1.3.16, but I bet something similar on 1.4.1:


    File /etc/php5/mods-available/ioncube_loader.ini



    Code
    1. ; priority=00zend_extension = /usr/lib/php5/20131226/ioncube_loader_lin_5.6.so

    Then:


    Code
    1. php5enmod ioncube_loaderservice php5-fpm restart

    Test with:

    Code
    1. php5 -v

  • Ok I will test I had to copy it into / etc / php5 / mods-available copy so it went.

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • Ok I will test I had to copy it into / etc / php5 / mods-available copy so it went.

    With latest i-MSCP Serie (1.4.x) the path for system PHP version is /etc/php/<php_version>/mods-available
    For PhpSwitcher PHP versions, read the documentation of the plugin.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206