mod_proxy_fcgi - 1.3.7 - apache 2 stretch

  • Hello,
    trying to upgrade to i-mscp 1.3.7 my jessie setup, but with apache2 from stretch (I need http2 support) i obtain this error when apache2 tries to start:

    Code
    1. Oct 26 20:19:36 tiger apache2[15025]: apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 2 of /etc/apache2/mods-enabled/proxy_fcgi.load: Cannot load /usr/lib/apache2/modules/mod_proxy_fcgi.so into server: /usr/lib/apache2/modules/mod_proxy_fcgi.so: undefined symbol: ap_log_rdata


    To avoid this I added this code to fix_apache2_mod_proxy_fcgi.sh :

    Code
    1. if [ -f /usr/lib/apache2/modules/mod_proxy_fcgi.so-DIST ] \
    2. || dpkg --compare-versions "$APACHE_VERSION" ge "2.4.23" ; then
    3. exit;
    4. fi

    In this case if version of apache is 2.4.23 or greater it doesn't try to patch it.


    Let me know if you have a better solution ;-)

  • @itcm


    I'll investigate but I need more info: you use Jessie with apache from stretch (by adding stretch repo in jessie) or you use Stretch?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • @itcm


    I'll investigate but I need more info: you use Jessie with apache from stretch (by adding stretch repo in jessie) or you use Stretch?

    I'm using Jessie, and apache2 from stretch because I need http2.

  • The patch works also under Stretch. Are you sure that you use Apache2 from Stretch?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • The patch works also under Stretch. Are you sure that you use Apache2 from Stretch?

    Yes, my installation is Debian Jessie with some packages pinned from stretch.
    Maybe this is the problem and in Debian Stretch everything works perfectly, maybe some dependencies for the proxy package...