solved - fail2ban problem w/ apache logfiles?

  • @fulltilt

    Fixed. This was due to the backend in use (gamin) which doesn't work correctly under Debian. For an unknow reason the backend was set to auto (gamin so). Once I've set it to polling, fail2ban has started correctly.
    Can you send me please a backup of your jail.conf file?

    BTW: You should put your conf in the /etc/fail2ban/jail.local file instead of /etc/fail2ban/jail.conf. This allow to not lost your configuration when fail2ban is updated.


    1. # "backend" specifies the backend used to get files modification. Available
    2. # options are "gamin", "polling" and "auto".
    3. # yoh: For some reason Debian shipped python-gamin didn't work as expected
    4. # This issue left ToDo, so polling is default backend for now
    5. backend = polling

    EDIT: jail.conf file restored (I've copied its content into the jail.local file, changed the backend to "polling", and then, restarted fail2ban). All is ok now.


  • nice work, sometimes debian is really silly ...
    thank you very much bro!
    I will hit the D button :D

    ### edit ###
    it works very well also with backend > polling

    1. 2014-07-01 16:21:52,917 fail2ban.actions: WARNING [ssh] Ban