opendkim bug with external mail server

  • Bug tracker does not work again !

    The problem is if you use opendkim with external mail server and if the external mail server does not sign the letters.

    DNS dkim option is discardable. This means .... my dns has the key and all mail server should sign it if they did not

    just drop the letter.

    This is a problem specially if you can not disable opendkim keys for specific domain.

    The easiest solution is to add option as it was on older panels to skip specific domain from opendkim key generation.

    We have the following solutions for that problem:

    1. Remove opendkim and do not use it if you have a client with external mail server.

    2. Use opendkim with external mail server but setup the keys at server side to sign.

    3. Fix i-mscp to add option for skip specific domain.

    I would pick option 3 for sure. This was the old behaviour and i do not know why you changed it ?!

    Let allow domain owner to choose if he wants dkim or not !

    I-mscp 1.5.3 - Build: 2018051

    OpenDkim: 2.0.0

    Debian 9

    I have reported that bug already but it says too old ... create new thread.

  • Hello,

    I am using the latest official stable panel:

    i-MSCP 1.5.3

    Build: 2018120800

    Codename: Ennio Morricone

    There is no newer than this.

    And do not install maintenance release from github except if you want to break your installation.....

    If you point me to a link for newer i-mscp panel i will get it.