HowTo: I-MSCP 1.5.3 installation on Debian 10

  • It is not really difficult to install I-MSCP stable on Buster ...

    I use PHP 7.0 with phpswitcher, mariadb 10.3 MUST be selected.

    - install debian 10

    1. nano /usr/local/src/imscp-1.5.3-2018120800/autoinstaller/Packages/debian-buster.xml


    1. nano /etc/apt/preferences.d/imscp
    2. # remove
    3. Package: libmariadbclient18 mariadb-client-10.1 mariadb-common mariadb-server-core-10.1 mysql-common
    4. Pin: release o=Debian,n=stretch
    5. Pin-Priority: 1001

    Important note:

    During the setup mariadb 10.3 MUST be selected, if the software installer is to be used PHP 7.0 must be installed as the default PHP version.


    1. perl imscp-autoinstall -d

    install PHPswitcher plugin

    install packaged PHP versions for PHPswitcher

    ## update see additional stuff ##

    HowTo: I-MSCP 1.5.3 installation on Debian 10

    Edited 7 times, last by fulltilt ().

  • if a dialog box (mysql user configuration) should appear during the installation you can simply click the back button to continue or intall mariadb 10.3 before the imscp installation:

    1. apt update && apt install mariadb-server -y
    2. mysql_secure_installation

    Edited once, last by fulltilt ().

  • It is best to test in a v-box beforehand, check everything under /etc/apt/* edit sources and remove old (debian9) pinning files

    1. sudo sed -i 's/stretch/buster/g' /etc/apt/sources.list
    2. sudo sed -i 's/stretch/buster/g' /etc/apt/sources.list.d/*

    Edited once, last by fulltilt ().

  • Thanks, I setup everything in a VMware and it worked perfectly. I have now done the upgrade on production without any serious trouble. For some reason, sslcompression is not supported, I had to disable it in order to get apache2 firing up.

    1. SSLCompression
    2. This version of OpenSSL does not have any compression methods available, cannot enable SSLCompression

    Further, MariaDB 10.4 upgrade worked, too. So, on first sight, everything worked besides SSL compression.

    Does anybody of you know that error with OpenSSL?

  • Thanks for the Apache link, didn't find it myself.

    However, I have some issues with LetsEncrypt using Debian 10

    1. Traceback (most recent call last):
    2. File "/usr/local/sbin/certbot", line 6, in <module>
    3. from certbot.main import main
    4. File "/opt/", line 5, in <module>
    5. import logging.handlers
    6. File "/usr/lib/python2.7/logging/", line 26, in <module>
    7. import sys, os, time, cStringIO, traceback, warnings, weakref, collections
    8. File "/usr/lib/python2.7/", line 14, in <module>
    9. from _weakref import (
    10. ImportError: cannot import name _remove_dead_weakref at /var/www/imscp/gui/plugins/LetsEncrypt/backend/ line 834.

    I am not a Python programmer and I do not now the codes behind LetsEncrypt. Can anybody of you help?

    The GUI is not working (buttons etc).

  • Wow, thanks!

    Uncommenting that line made my GUI work again. Still, I got an error about Python packages.

    I was able to fix them following the URL…ails-after-upgrade.77911/

    After that, I was able to trigger the process via I-MSCP GUI with success!

    Looking forward to the next upgrade problem :-)

  • Hi, I followed the instructions, it worked like a charme.

    Installing Plugins was possible, too.

    But: I cannot create folder access control, and switching the language is not possible, it stays on "browser detected" (Automatisch (Browsereinstellung)).

    Has anybody experienced similar problems?

    Edit: Even worse: The same error when I try to change the document root, but I need that to deploy a symfony based project I'm writing for a customer.

    I'll try to change it in the Apache conf, but that will break anytime I update something via panel.

    Edited once, last by tracer ().