Install PHP 7.4 or later

  • Hello

    i-MSCP 1.5.3 Build: 2018120800 comes with some version of PHP 7.1. WordPress keeps telling me that is not a secure PHP version today. So I was considering to upgrade to PHP 7.4 or later. Can anyone point me to the right guidance?


    Note: I also have purchased PHP Switcher plug-in.

  • I'm not a WP Guy, but give it a try.


    I think WP used the system default /usr/bin/php, not the compiled /opt versions. You have to tell WP where to find the PHP version.


    I don't think my command is correct, but give it a try.


    i.e.

    In your WP Docroot.

    # /opt/phpswitcher/[COMPILED_DATE]/php7.3/bin/php wp core update

    Es gibt viele Wege Danke zu sagen, der Einfachste ist das auch zu tun.


    Herzlichen Dank - Merci beaucoup -- Большое спасибо -- Thank you very much -- Muchas gracias

    Edited once, last by rabuntu ().

  • rabuntu: WP upgrades itself from within the webgui - so it uses the php version which is configured in apache...


    Omi Azad: Use phpswitcher an first try php 7.3...


    Without phpswitcher it's alot of manuel work... I think there are many posts about this topic in the forum...


    /J

  • WP upgrades itself from within the webgui - so it uses the php version which is configured in apache...

    Yes you are right, but you can upgrade WP over CLI too.

    https://www.dreamhost.com/blog…core-command-line-wp-cli/


    I know the content of the link is a bit old, but I think it still works today.

    Es gibt viele Wege Danke zu sagen, der Einfachste ist das auch zu tun.


    Herzlichen Dank - Merci beaucoup -- Большое спасибо -- Thank you very much -- Muchas gracias

  • I have PHPswitcher. How do I switch between versions if I am not able to install other versions?

  • normally the customer can switch in the domain menu... but maybe in another version it's different...