Lets Encrypt Fehler

  • Code
    1. I-MSCP - Version: i-MSCP 1.5.3 Build: 2018120800
    2. Server: Ubuntu 18.04.4 LTS

    Hallo zusammen, heute habe ich mir das Plugin "Lets Encrypt" gekauft, die Installation lief komplikationslos.

    nach dem ich zum Testen ein Zertifikat für einen Benutzer erstellen wollte ist folgende Fehlermeldung erschienen


    Code
    1. Failed authorization procedure. DOMAIN.XX (http-01): urn:ietf:params:acme:error:dns :: No valid IP addresses found for DOMAIN.XX at /var/www/imscp/gui/plugins/LetsEncrypt/backend/LetsEncrypt.pm line 834.

    wobei das "DOMAIN.XX" schon die richtige domain gewesen ist, da ich keine Werbung machen möchte, habe ich diese Fehlermeldung editiert.


    ich habe mich bestengewissens an die "Readme.MD" gehalten, somit bin ich mir keinen Fehler bewusst.


    Lg Mattes

  • Es wird dir bereits gesagt, was das Problem ist.

    Die IP Konfiguration für die Domain ist nicht gültig.

    Have a nice day. :)

  • Es wird dir bereits gesagt, was das Problem ist.

    Die IP Konfiguration für die Domain ist nicht gültig.

    DNS-Server seitig oder vom Webserver?


    leider finde ich dazu kein passendes howto, wenn ich ein zertifikat für eine Subdomain erstelle, bekomme ich da keinerlei probleme.

  • Sind die Domains auf dem selben Server bzw. DNS-Server? Domain und Subdomains können auch unterschiedliche IPs und DNS Settings haben.

    Gucke mal in i-MSCP, ob die IP Einstellungen für die Domain und Subdomain richtig sind bzw. gleich sind.

    Danach sonst mal beim Hoster gucken, ob die DNS Einstellungen der problematischen Domain etwas suboptimal ist.

    Have a nice day. :)

  • Code
    1. s.u.!!!!

    eine separate DNS Einstellung wurde über i-mscp nicht vorgenommen.

    also Subdomain "*" geht an die gleiche ip wie "www"

    Edited once, last by matteskr: Fehler gefunden! ().

  • Mein Fehler :-)


    die domains

    "*.blabla.bla"

    sowie "http://www.blabla.bla" waren anständig eingerichtet

    nur "blabla.bla" war nicht anständig im Nameserver eingestellt!

    jetzt geht alles ohne Probleme!


    danke

  • FloRet88

    Closed the thread.
  • FloRet88

    Added the Label brain failure