LetsEncrypt installation failed on line 266.

  • Goog evening.

    I just bought the LetsEncrypt Plugin and tried to install it. But it always just ends in an unexpected Error:

    1. Plugin::LetsEncrypt::enable: E: Unable to correct problems, you have held broken packages. at /var/www/imscp/gui/plugins/LetsEncrypt/backend/LetsEncrypt.pm line 266

    But even after reading some posts like LetsEncrypt 3.5.0 install fails (due to SSL version?) on Debian 9.11 and "all Debian updates" I was not able solve the problem.

    I'm not quite sure which information you need to help me so I just give you some input:

    vServer: Debian 9.11

    i-MSCP 1.5.3 Build: 20180516 Codename: Ennio Morricone

    LetsEncrypt: 3.5.0 (Build 2018071900)

    Thanks for your Help :thumbsup:


    Edited once, last by Revi ().

  • Well, the log says:

    1. you have held broken packages

    So, try to run apt update and the apt upgrade

    You'll see the error and you should be able to correct it

  • And also update to latest stable I-MSCP Release - otherwise no more Support is provided!

    Support Infos: I-MSCP Version: 1.5.x / Distro: Debian Stretch / PHP: 7.1.27 - FPM / I-MSCP Plugins: Let´s Encrypt + PHPSwitcher (latest Versions)

  • While trying to resolve the Problems with MariaDB 10.2 vs. libmariadbclient18 I bricked the whole database configuration so that I had to hard-reinstall the vServer.

    After that, this problem was solved, too.