Switcher 5.0.5 - Compile Errors

  • Receive this error on compile for 7.1 > 7.3 didn't test 7.4 / 7.0

    Removing imscp-psw-php7.2-runtime-dependencies (1.0) ...

    [ERROR] main: An error occurred while installing PHP 7.2 runtime dependency package: Unmet dependencies.

    tested on two servers both Debian 9 Stretch.

    5.0.3 was installed > went direct to 5.0.5 skipping over 5.0.4


  • Please, check you apt sources.list file and make sure that the ondrey sury repositories are enabled.


  • repo in my apt

    1. deb https://packages.sury.org/php/ stretch main

    is that not correct?

    seemed to work fine on 5.0.3... just some odd php errors recently on 7.1.x but resolved by switching over to 7.2/7.3

    having some trouble enabling bcmath/ gd / imagik and some other addons though.

    gd / imagick / bcmath for all versions

    expect after installing those extensions need to re-compile.

    Edited once, last by viper_iii ().

  • removed - old repo and re-addeded using: below

    1. apt-get install apt-transport-https lsb-release ca-certificates
    2. wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
    3. echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/php.list

    re-running - compile again currently.

  • newer system 7.4 errors out similar unmet dependency error -

    but gets through 7.1>7.3 without errors

    running 7.0 and 7.4 now again just to test

    older server 7.3 failed 7.1>7.2 appear to have worked...

    as its building I do see it grabbing jessie updates for building - expect that is pinned specifically for the compile script.

  • Newer System

    1. The following packages will be REMOVED:
    2. imscp-psw-php7.0-runtime-dependencies
    3. 0 upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
    4. 1 not fully installed or removed.
    5. After this operation, 11.3 kB disk space will be freed.
    6. (Reading database ... 71842 files and directories currently installed.)
    7. Removing imscp-psw-php7.0-runtime-dependencies (1.0) ...
    8. [ERROR] main: An error occurred while installing PHP 7.0 runtime dependency package: Unmet dependencies.

    then re-run for 7.0 only and registers right up

    both systems worked fine just re-executed

    1. perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl --register 7.4
    2. [DONE] PHP versions scheduled for update:
    3. - PHP 7.4 (Compiled)
    4. [INFO] Processing of PHP versions in progress. Please be patient...
    5. [DONE] PHP versions were processed.

    doesn't make any sense - expect my configs are messed up..

    but appears to work...

  • Hi viper_iii

    I've got the same issue with php 7.2 and tried the 3 steps in your 3rd post.

    Unfortunately still the same issue.

    i-mscp 1.5.3 (2018120800)

    UPDATE: looks like one "apt-get update" after the three commands helped.

    stay hungry, stay foolish!

    Edited once, last by nextx42 ().