Posts by viper_iii

    Newer System

    Code
    1. The following packages will be REMOVED:
    2. imscp-psw-php7.0-runtime-dependencies
    3. 0 upgraded, 0 newly installed, 1 to remove and 2 not upgraded.
    4. 1 not fully installed or removed.
    5. After this operation, 11.3 kB disk space will be freed.
    6. (Reading database ... 71842 files and directories currently installed.)
    7. Removing imscp-psw-php7.0-runtime-dependencies (1.0) ...
    8. [ERROR] main: An error occurred while installing PHP 7.0 runtime dependency package: Unmet dependencies.

    then re-run for 7.0 only and registers right up


    both systems worked fine just re-executed


    Code
    1. perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl --register 7.4
    2. [DONE] PHP versions scheduled for update:
    3. - PHP 7.4 (Compiled)
    4. [INFO] Processing of PHP versions in progress. Please be patient...
    5. [DONE] PHP versions were processed.



    doesn't make any sense - expect my configs are messed up..

    but appears to work...

    newer system 7.4 errors out similar unmet dependency error -

    but gets through 7.1>7.3 without errors

    running 7.0 and 7.4 now again just to test

    ---
    older server 7.3 failed 7.1>7.2 appear to have worked...

    as its building I do see it grabbing jessie updates for building - expect that is pinned specifically for the compile script.

    removed - old repo and re-addeded using: below

    Code
    1. apt-get install apt-transport-https lsb-release ca-certificates
    2. wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
    3. echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" | sudo tee /etc/apt/sources.list.d/php.list

    re-running - compile again currently.

    repo in my apt


    Code
    1. deb https://packages.sury.org/php/ stretch main


    is that not correct?


    seemed to work fine on 5.0.3... just some odd php errors recently on 7.1.x but resolved by switching over to 7.2/7.3


    having some trouble enabling bcmath/ gd / imagik and some other addons though.


    gd / imagick / bcmath for all versions


    expect after installing those extensions need to re-compile.

    Receive this error on compile for 7.1 > 7.3 didn't test 7.4 / 7.0


    Removing imscp-psw-php7.2-runtime-dependencies (1.0) ...

    [ERROR] main: An error occurred while installing PHP 7.2 runtime dependency package: Unmet dependencies.


    tested on two servers both Debian 9 Stretch.

    5.0.3 was installed > went direct to 5.0.5 skipping over 5.0.4


    Ideas?

    went into imscp_user to edit database and remove messed up phpswitcher

    and associated switcher tables completely

    copied data to be able to correct domains later


    This allowed me to re-upload 5.0.2 and install correctly


    now testing php installs


    purge pbuilder

    cd /var/cache

    rm -rf pbuilder

    install pbuilder

    install cowbuilder


    Code
    1. perl /var/www/imscp/gui/plugins/PhpSwitcher/PhpCompiler/php_compiler.pl --register 7.2

    processing as expected now - monitoring for any issues.

    Highly suspect my own configuration issues vs any programming bugs!

    Code
    1. No LSB modules are available.
    2. Distributor ID: Debian
    3. Description: Debian GNU/Linux 9.11 (stretch)
    4. Release: 9.11
    5. Codename: stretch

    humm....

    apparently I'm on V9 and didn't even notice...

    I'm wondering if there is some serious issues in there now!!!!


    don't remember that upgrade ever working - my documentation (poor as it is) shows I reverted to a snapshot to get back online...

    ...



    Code
    1. mysql --version
    2. mysql Ver 14.14 Distrib 5.7.27, for Linux (x86_64) using EditLine wrapper
    Code
    1. Version = 1.5.3
    2. Build = 2018120800

    5.0.1 installed fine


    had errors as shown about pbuilder

    played a bit with the other items and still no resolution


    went to update to 5.0.2 and got the upgrade error


    doing as you mentioned now....


    apt purge pbuilder

    apt autoremove

    rm -f /pbuilder (was in /var/cache/)


    re-attempt update plugins no change still maintains error on phpswitcher


    Code
    1. Plugin update has failed: SQLSTATE[42000]: Syntax error or access violation: 1061 Duplicate key name 'version_version'



    package-5.0.2.JPG

    Debian 8

    Current I-mscp 1.5.3

    mysql Ver 14.14 Distrib 5.7.27



    5.0.2 Upgrade of php-switcher Error on upgrade


    Code
    1. Plugin update has failed: SQLSTATE[42000]: Syntax error or access violation: 1061 Duplicate key name 'version_version'



    ----
    5.0.1 Errors on compile


    Code
    1. I: forking: rm -rf /var/cache/pbuilder/build/cow.5749
    2. [ERROR] main: An error occurred while setup of PHP build environment: cp: cannot create regular file '/var/cache/pbuiow.5749/etc/hosts': No such file or directory
    3. E: pbuilder update failed


    found some errors online with other pbuilder, related to cowbuilder --create needing to be executed

    on execution found this error:


    Code
    1. I: Validating zlib1g 1:1.2.11.dfsg-1+b1
    2. I: Chosen extractor for .deb packages: dpkg-deb
    3. I: Extracting libacl1...
    4. E: debootstrap failed
    5. W: Aborting with an error
    6. E: pbuilder create failed


    (probably something specific to this system


    tested 5.0.1 on a Deb 9 System (that was updated from Deb8 a few months ago) - and everything worked smoothly

    compile and updates all, no issue - think the Deb 8 above, has other issues Unrelated to i-MSCP

    But wanted to update on errors just in case others have them as well.


    :thumbsup: