PhpSwitcher plugin - Unknown column 'domain_name'

  • test server 2:

    fresh install debian 9

    latest imscp (auto install)

    php version 7.2

    plugins: dkim, php switch, lets encrypt


    logfile: letsencrypt-plugin-pending.pl.log

    [Fri Aug 9 13:00:02 2019] [error] main: Couldn't process Let's Encrypt pending tasks: Unknown column 'domain_name' in 'field list' at /var/www/imscp/gui/plugins/PhpSwitcher/backend/PhpSwitcher.pm line 61.

    ...propagated at /var/www/imscp/gui/plugins/LetsEncrypt/cron/../../../../engine/PerlLib/iMSCP/DbTasksProcessor.pm line 496.


    When i click on php switcher i get this error

    SQLSTATE[42S22]: Column not found: 1054 Unknown column 'version_version' in 'field list'


    is there something i can do to fx this

    or do i do a reinstall and see if i made an error

    at this moment the ssl cert is not working for the domain

    wt nx mr lr snl

  • switched off php switcher plugin that gave me a error aswell

    could not remove php switcher

    but it fxt the problem ssl cert is working now

    and that thing from progress on the user is also changed in complete


    is there something going on between php Switcher and php7.2 ?

    i mean i only chose the 7.2 while installing the imscp and added the plugin afterwards

    wt nx mr lr snl

  • ok so in order to use php Switcher i can not choose the php7.2 when i am installing the imcp correct ?


    i thought i just install 7.2 and then use the phpswitcher for lower versions

    but anyway its the test server i never do stuff like this on my running server


    by the way mail did not work either

    now that i pressed turn off php switcher mails work also

    wt nx mr lr snl

  • If you use php 7.2 and newer, it wont work with i-MSCP and the php Switcher.

    7.2 and newer will be supported in the next release (from what I read).

    Have a nice day. :)

  • i mean i only chose the 7.2 while installing the imscp and added the plugin afterwards

    So, the question here is: Which i-MSCP version did you installed exactly? In the latest released i-MSCP version, PHP 7.2 isn't supported... So it seem you installed the development version of i-MSCP...

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • So, the question here is: Which i-MSCP version did you installed exactly? In the latest released i-MSCP version, PHP 7.2 isn't supported... So it seem you installed the development version of i-MSCP...

    i-MSCP 1.5.3
    Build: 2018120800
    Codename: Ennio Morricone


    dont know if thats a develope version either just got it from here clicked on your link and downloaded it

    then i followed the install instructions in the docs/debian and then i choose auto install

    after that i get to choose what php version i want i choose 7.2


    once it was completed i added the plugins

    after that i noticed the mail did not work and the ssl did not work and the user add was not completed


    anyway did i choose the wrong version I-Mscp ?

    wt nx mr lr snl

  • That seems to be the right one. But that version doesnt support php 7.2.^^

    Did you download it from the official links?

    Have a nice day. :)

  • That seems to be the right one. But that version doesnt support php 7.2.^^

    Did you download it from the official links?

    well like i say before i just followed the install instructions in the docs/debian

    then i choose auto install

    then when you get to the point of choosing the php version i choose the highest php version


    Copyright (c) 1997-2018 The PHP Group

    Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies

    with Zend OPcache v7.1.31-1+0~20190807.22+debian9~1.gbpf402ed, Copyright (c) 1999-2018, by Zend Technologies


    sorry my mistake it should be this one 7.1.31

    wt nx mr lr snl

  • Well, thats not 7.2.^^


    Still, you tried to add 7.2 to the php Switcher right? Its not fit for that.

    Have a nice day. :)