Debian 10 (Buster)

  • right, sorry, it wasn't php-7.2 - that was for stretch, I installed 7.3 from default buster repo, but didn't work either. Error had nothing to do with php... the installation just couldn't continue properly.


    I installed all the requirements from the debian-buster.xml, but no luck

  • joximu


    Hi

    I tested the last "nightly" (july 3rd) on devuan ascii - the installation requires lots of packets I had to install manually (this is not common in i-mscp) - and at the end I hat to install PHP - but the only PHP I got from devuan ascii (is equal to debian 9) is a php 7.0.x - which is "to old for i-mscp...


    Which version you tried to install exactly? Give me the exact link you used please ;) I'm asking that because I'm pretty sure that you tried with the wrong branch... The github branch to use is https://github.com/i-MSCP/imscp/tree/1.5.3-maintenance.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • joximu



    Which version you tried to install exactly? Give me the exact link you used please ;) I'm asking that because I'm pretty sure that you tried with the wrong branch... The github branch to use is https://github.com/i-MSCP/imscp/tree/1.5.3-maintenance.

    Hi Nuxwin,


    I did a "git clone https://github.com/i-MSCP/imscp.git" on buster - this should lead me to 1.5.3-maintenance, right?


    Edit:

    just did another clean install of buster


    Code
    1. sudo apt-get -y --auto-remove --no-install-recommends install ca-certificates perl whiptail wget


    Code
    1. [email protected]:~/imscp$ git branch
    2. * 1.5.3-maintenance


    Code
    1. [email protected]:~/imscp$ sudo perl imscp-autoinstall -d
    2. [FATAL] autoinstaller::Adapter::DebianAdapter::_getPackagesDialog: Can't locate XML/Simple.pm in @INC (you may need to install the XML::Simple module) (@INC contains: /home/catscrash/imscp /home/catscrash/imscp/engine/PerlLib /home/catscrash/imscp/engine/PerlVendor /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.28.1 /usr/local/share/perl/5.28.1 /usr/lib/x86_64-linux-gnu/perl5/5.28 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.28 /usr/share/perl/5.28 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /home/catscrash/imscp/autoinstaller/Adapter/DebianAdapter.pm line 932.

    I could go and install this package now, but the missing packages just keep coming. That's what I had last time as well. I installed everything from the debian-buster.xml requirements-section manually last time, but then something else failed. I'm happy to try that again if it helps you to get a more detailed error message of what failed later on

    Edited 2 times, last by Catscrash ().

  • Hi Nuxwin,


    I did a "git clone https://github.com/i-MSCP/imscp.git" on buster - this should lead me to 1.5.3-maintenance, right?

    Yes since default branch is the 1.5.3-maintenance ;) But you don't say us the error you get... Anyway, there are several changes not committed yet... I'll try to make it working for tomorrow.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Yes since default branch is the 1.5.3-maintenance ;) But you don't say us the error you get... Anyway, there are several changes not committed yet... I'll try to make it working for tomorrow.

    Hi,


    sorry about that, I edited my earlier answer before I saw your message. There's more detail now

  • Hi,


    sorry about that, I edited my earlier answer before I saw your message. There's more detail now

    I'll check and fix...

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • This is due to a bad flag... In the autoinstaller/Adapter/DebianAdapter.pm at line 77:


    Code
    1. iMSCP::Getopt->skipDistPackages( TRUE );

    should be

    Code
    1. iMSCP::Getopt->skipDistPackages( FALSE );


    But, there is maybe other bugs... I'll check and commit soon.


    BTW: This at least show how a little single change can break everything... 8o

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Thanx I'll try...


    > BTW: This at least show how a little single change can break everything... 8o


    This has already been proven in many other projects... you don't need to prove again :-))

  • Thanx I'll try...

    Don't please, there are surely other bugs. At least, I'm sure of one:



    ouch.png


    Should not occurs on fresh install and even worse the fact that pressing enter don't show is a NOOP (unexpected)...

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206