PHPSwitcher - Unable to compile 5.6 (Debian 8.11)

  • Hi Nuxwin ,

    I would have loved to not bother you, but... yeah, don't know what's going on there.

    I've got the same issue stated there : Error Compiling PHP Versions for PHP Switcher

    I did apply the "downgrade" package, it did work (for the downgrade) but... after I try the compile again, it fail, take some more time to get into the error and give a bunch of text, but the error remain :/

    Debian : 8.11

    iMSCP : Latest (1.5.3-2018120800)

    PHPSwitcher : 4.0.3

    Command run : perl --auto-setup --skip-builddeps 5.6 7.0 7.1

    Solutions applied :

    - this PhpSwitcher plugin (4.0.3) - Build dependency problem on Debian Jessie

    - and this Error Compiling PHP Versions for PHP Switcher

    I keep searching on my end, but maybe you already have the solution :)


    The error log :

    The installed version of both packages (downgraded):

    EDIT : Possible fix (PHP 5.6.32, 7.0.25 and PHP 7.1.11), please confirm this way Nuxwin :) :

    For this error only.


    /usr/bin/ld.bfd.real: /usr/lib/x86_64-linux-gnu/libc-client.a(osdep.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC

    /usr/lib/x86_64-linux-gnu/libc-client.a: error adding symbols: Bad value

    Fix :


    rm /usr/lib/x86_64-linux-gnu/libc-client.a

    ln -s /usr/lib/ /usr/lib/x86_64-linux-gnu/libc-client.a

    Fix worked for me at least, ouf :


    [DONE] The install MAKE(1) target has been successfully executed for php-5.6.32

    [DONE] PHP versions scheduled for addition: 5.6

    [DONE] PHP versions scheduled for update: 7.0, 7.1

    Edited 5 times, last by Athar ().

  • Athar

    Added the Label solved
  • Nuxwin

    Closed the thread.