Upgrade from 1.1.21 to 1.5.3

  • Hello, I have a really old install and I would like to upgrade to 1.5.3, is it possible without breaking anything? I've read the forum for similar posts but didn't find anything so old. I've made backups for everything but I still want to be sure that it's possible to update to the latest version from something this old without major issues.

    Current :

    i-MSCP 1.1.21
    Build: 20141230
    Codename: Eagle


  • Good evening,

    The upgrade path from 1.1.x version is currently broken. We will fix the problem this week.


  • Nuxwin

    Added the Label to be fixed
  • Thank you very much for your reply, I'll check back next week than. The reason i'm trying to upgrade is because custumers can no longer add some email accounts. The accounts are stuck in "Addition in progress" and users can't login.

    The output of perl /var/www/imscp/engine/imscp-rqst-mngr -v is :

    1. Processing Mail items.Processing 3767, [email protected], toadd. (1 of 3: remaining 2)
    2. [ERROR]
    3. main::_process: Error while processing 3767, [email protected], toadd.
    4. main::_process: See /var/log/imscp/[email protected] for more details.
    5. iMSCP::Debug::END: Exit code: 1
    6. [ERROR]
    7. Modules::Mail::_loadData: Error while executing query: In aggregated query without GROUP BY, expression #1 of SELECT list contains nonaggregated column 't2.mail_addr'; this is incompatible with sql_mode=only_full_group_by

    Any help on this matter would be greatly appreciated :)

  • Victor Faur

    This error occurs because you've updated the SQL server to a newest version. You should be able to fix the problem as follows:

    1. Create a specific configuration file to switch back to default MySQL 5.5 behavior by running the following command:

    1. printf "[mysqld]\nsql_mode=\n" > /etc/mysql/conf.d/sql_mode.cnf

    2. Restart the MySQL server:

    1. service mysql restart

    3. Process the pending i-MSCP backend requests

    1. perl /var/www/imscp/engine/imscp-rqst-mngr -dv

    See also

    Regarding the change that affects you: https://dev.mysql.com/doc/refm…qlmode_only_full_group_by


  • Nuxwin that was awesome, everything works now, thanks a lot !! :thumbsup:

    You're welcome. Thread closed.


  • Nuxwin

    Closed the thread.
  • Nuxwin

    Set the Label from to be fixed to solved