i-mscp on Ubuntu 18.04 Bionic Beaver

  • Hi everybody, i have a server which was upgraded from ubuntu 12.04 to 14.04, 16.04 and finally to 18.04. i-mscp was running fine with no problems on 12.04 but it doesn't work at all on 18.04. I tried installing different versions, 15.1, 15.3, 1.6.x and each one fails with a different error. The latest one from the 1.6.x branch is :


    [ERROR] │
    │ │
    │ Error while performing step: │
    │ │
    │ Removing obsolete files │
    │ │
    │ Error was: │
    │ │
    │ Caught a SIGPIPE at /usr/local/src/imscp-1.6.x/backend/PerlLib/iMSCP/Stepper.pm line 141.


    Any ideeas / suggestions on how to fix this mess and install a working version of i-mscp without losing settings / configs ?

    I have to specify that downgrade back to 16.04 is no longer possible since it's a remote system with access over ssh and the really bad news, it's a production server, so it needs fixing asap.


    Thanks.

  • Victor Faur


    The 1.6.x branch is under heavy development. You cannot use it ATM.

    For the 1.5.x Serie, support for Ubuntu 18.04 (Bionic Beaver) will be added in the 1.5.4 version.


    Next time, think a bit before acting.

    Thread closed.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Nuxwin

    Added the Label question (answered)
  • Nuxwin

    Closed the thread.