Migrate from ispCP 1.0.7 to i-MSCP

  • I am trying to migrate very old machine to more new i-mscp.

    I choosed 1.1.21 so i can be closer.

    Migrate script went fine.

    Now when running the final: perl imscp-setup

    I have the following error:

    -----------------------------------------


    [ERROR]


    iMSCP::Addons::ComposerInstaller::_getComposer:


    [RuntimeException]

    Invalid working directory specified, =/var/cache/imscp/addons does not exist.



    iMSCP::EventManager::trigger: A listener registered on the 'afterSetupPreInstallAddons' event and triggered in main::setupPreInstallAddons has failed.


    Listener code was:


    sub {

    package iMSCP::Addons::ComposerInstaller;

    use warnings;

    use strict 'refs';

    'iMSCP::Dialog'->getInstance->endGauge;

    my $rs = 'iMSCP::Dir'->new('dirname', $$self{'wrkDir'})->make;

    return $rs if $rs;

    $rs = $self->_clearLocalRepository if 'iMSCP::Getopt'->cleanAddons;

    return $rs if $rs;

    unless ('iMSCP::Getopt'->skipAddonsUpdate and -x "$$self{'wrkDir'}/composer.phar") {

    $rs = $self->_getComposer;

    return $rs if $rs;

    }

    if (not 'iMSCP::Getopt'->skipAddonsUpdate or $self->_checkRequirements) {

    $rs = $self->_installPackages;

    }

    $rs;

    }


    iMSCP::Debug::END: Exit code: 1


    -------------------------------------------------


    /var/cache/imscp/addons - exists.

    I know this is so old but will save me much time if i can upgrade it.

  • sanitariu


    Good morning,


    The best you can do for a migration from ispCP is to process the database updates only till you reach the i-MSCP 1.5.3 version then run a normal 1.5.3 upgrade. Of course some cleanup of the old ispCP pieces would be required.


    Remember that we are providing support for upgrade. If no distribution upgrade is needed, the cost woul be relatively low.


    See https://i-mscp.net/wcf/index.php?user/650-nuxwin/#about


    Why choose us for such a task? We have been part of ispCP core development team and we're developing i-MSCP. The choice is left to you of course but you should really considere our offer.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Nuxwin

    Changed the title of the thread from “Migrate ispcp-1.0.7 to i-mscp 1.1.21” to “Migrate from ispCP 1.0.7 to i-MSCP”.
  • Nuxwin

    Added the Label question (answered)
  • Thanks,

    I will do until 1.5.3.

    I am not sure if now i am at some middle broken setup or i can take another imscp version like 1.2.16 and start again the migrate process ?

    I think 1.1.21 have brokern ComposerInstaller.pm or something like that. Can i disable at all ?


    Regards,

  • Thanks,

    I will do until 1.5.3.

    I am not sure if now i am at some middle broken setup or i can take another imscp version like 1.2.16 and start again the migrate process ?

    I think 1.1.21 have brokern ComposerInstaller.pm or something like that. Can i disable at all ?

    If you do the job by yourself, you must know what you do ;) There is a standalone PHP script making possible to update the database. Thus, you should be able to run it for i-MSCP version 1.1.21, then, version 1.3.8, then upgrade normally to version 1.5.3. No need to run the PHP script for other intermediate versions. If you read the i-MSCP errata files, you will known why. Note that you'll have to cleanup the system from any ispCP piece before running the i-MSCP installer and of course, we will not give you the list of them.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Hello,

    My problem is getting to version 1.1.21.

    I think ComposerInstaller.pm have some bug in that version and stops the install. Can i somehow skip all ComposerInstaller.pm

    www:/var/www/imscp/engine/setup# perl imscp-setup --skip-addons-update

    Does not help at all.


    Sorry for taking your time.

    Regards,

    Todor

  • If you do the job by yourself, you must know what you do

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • I tried version 1.3.5.

    www:/usr/src/imscp-1.3.5# ./imscp-autoinstall -d


    This is what i got:


    iMSCP::Composer::_installPackages: Could not install/update i-MSCP packages from GitHub │

    │ │

    │ Please have a look at http://i-mscp.net/forum if you need help.


    I think this should print more information about what is the error.

    Is there anyway to disable at all Composer packages ?

    I do not need roundcube/awstats or anything like that.

  • sanitariu


    Just do what I've said in my previous answer.

    Thread closed.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

    account_detailed.gif

  • Nuxwin

    Closed the thread.