Installation failes - No installation candidate (dovecot-core and ifupdown)

  • Hi,

    I'm installing i-MSCP 1.5.1 on a new server (Debian 9.4) and get the following error:

    autoinstaller::Adapter::DebianAdapter::installPackages: Couldn't install packages: Reading package lists...Building dependency tree...Reading state information...Package ifupdown is a virtual package provided by: netscript-2.4 5.5.1 ifupdown2 1.0~git20170314-1

    Package dovecot-core is not available, but is referred to by another package.This may mean that the package is missing, has been obsoleted, oris only available from another sourceHowever the following packages replace it: dovecot-sieve dovecot-ldap dovecot-dev

    E: Package 'dovecot-core' has no installation candidateE: Package 'ifupdown' has no installation candidate

    I am able to install these packages manually (ifupdown from stretch repo (with a bug warning) and dovecot-core from backports), however, even after installation of the packages and disabling 10apt-listbugs I still get the same error when running the installer.

    Is there a known issue? What can I do to omit the installation of these packages by the i-MSCP installer?

    Regards, Sven.

  • You've done something wrong.

    1. root@dev:~# lsb_release -aNo LSB modules are available.Distributor ID: DebianDescription: Debian GNU/Linux 9.4 (stretch)Release: 9.4Codename: stretch

    Both packages should be available. Note that we have installed i-MSCP 1.5.1 several times on Debian Stretch without any problem. The problem is on your side. You should check your /etc/apt/sources.list file and also any file from the /etc/apt/sources.list.d directory.