SpamAssassin Update Problem

  • Hi all and happy new year! :)

    I tried to update an small virtual machine that i am administrating for friends. Before the update it was on i-mscp 1.3.16. I did the usual apt update & upgrade and upgraded to i-mscp 1.5.1. The update went through without any problems. No errors! After the upgrade i logged into i-mscp and wanted to upgrade the installed plugins.

    ClamAV, PolicydWeight and Postgrey updatet to the latest versions without any problems.

    The last installed Plugin that is installed on that machine, caused some problems. SpamAssassin! First of all, after uploading the File the Panel didn't responded anymore. It took more than 5 minutes(with the panel not responding) before the update of that Plugin was in an state of error. The error says:

    1. Plugin-Aktualisierung fehlgeschlagen: SQLSTATE[HY000]: General error: 3 Error writing file '/tmp/MYH9utSe' (Errcode: 28)

    I have found that thread:…d/?postID=57371#post57371

    But no solution to fix that problem.

    The System is an small Virtual Machine.

    lsb_release -a

    1. Distributor ID: DebianDescription: Debian GNU/Linux 8.10 (jessie)Release: 8.10Codename: jessie

    i-mscp 1.5.1

    uname -a

    1. Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.51-3 (2017-12-13) x86_64 GNU/Linux

    df -h

    1. Dateisystem Größe Benutzt Verf. Verw% Eingehängt auf/dev/sda1 90G 44G 42G 51% /udev 10M 0 10M 0% /devtmpfs 794M 8,5M 785M 2% /runtmpfs 2,0G 0 2,0G 0% /dev/shmtmpfs 5,0M 0 5,0M 0% /run/locktmpfs 2,0G 0 2,0G 0% /sys/fs/cgroup

    df -i

    1. Dateisystem Inodes IBenutzt IFrei IUse% Eingehängt auf
    2. /dev/sda1 5996544 973241 5023303 17% /
    3. udev 505500 324 505176 1% /dev
    4. tmpfs 507599 487 507112 1% /run
    5. tmpfs 507599 1 507598 1% /dev/shm
    6. tmpfs 507599 10 507589 1% /run/lock
    7. tmpfs 507599 13 507586 1% /sys/fs/cgroup

    SpamAssassin 2.0.1

    I checked the imscp_spamassassin mysql db.(Don't know if it is needed but saw it on the other thread. Better more than less information ;) )

    bayes_seen 17056 entrys
    bayes_token 216695 entrys
    bayes_vars 84 entrys

    Thanks a lot in advance for any useful answer! :)


  • I don't know why, but it worked now.

    Wanted to debug and get more information what is wrong. So i stopped the daemon, retried the plugin and started the daaemon with "perl /var/www/imscp/engine/imscp-rqst-mngr -v".

    No errors appeared and the plugin is active now. Strange! But as long as it works.....

    Thanks anyway and sorry for the thread. Can be closed! :)


  • badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Nuxwin

    Closed the thread.
  • Nuxwin

    Added the Label patched