PhpSwitcher error install php-imagick

  • Moin @Nuxwin


    So I just have with these instructions


    PhpSwitcher error install php-imagick


    and get the following error message from the installation

    What can I do to make it work @Nuxwin


    my System :


    - Distribution: Debian | Release: 8.9 | Codename: jessie

    - i-MSCP Version: i-MSCP 1.5.1| Build: 20170908 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)

    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)


    https://www.4sync.com/web/r/dwMJ2VT4

  • @Speedy


    There is not bug here...


    configure: error: not found. Please provide a path to MagickWand-config or Wand-config program.

    Basically, you need first install the required development libraries:


    Shell-Script
    1. # apt-get install libmagickwand-dev

    Once done, retry.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • very nice. That works


    You can close.

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)


    https://www.4sync.com/web/r/dwMJ2VT4