Update to 1.5.1 - You have held broken packages

  • Moin Nuxwin



    If you were there again I have just tried to make an update to 1.5.1 and get the following error message I have nothing changed nothing.





    What can I do Nuxwin



    Shell-Script
    1. [ERROR] autoinstaller::Adapter::DebianAdapter::installPackages: Couldn't install packages: Reading package lists...Building dependency tree...Reading state information...apt-src is already the newest version.at is already the newest version.bash is already the newest version.bzip2 is already the newest version.ca-certificates is already the newest version.coreutils is already the newest version.cron is already the newest version.curl is already the newest version.devscripts is already the newest version.dovecot-core is already the newest version.dovecot-imapd is already the newest version.dovecot-mysql is already the newest version.dovecot-pop3d is already the newest version.dpkg-dev is already the newest version.findutils is already the newest version.gcc is already the newest version.gzip is already the newest version.iproute is already the newest version.iptables is already the newest version.ispell is already the newest version.libapache2-mod-fcgid is already the newest version.libcrypt-blowfish-perl is already the newest version.libcrypt-cbc-perl is already the newest version.libcrypt-eksblowfish-perl is already the newest version.libcrypt-rijndael-perl is already the newest version.libdata-validate-ip-perl is already the newest version.libdate-simple-perl is already the newest version.libdatetime-perl is already the newest version.libdbd-mysql-perl is already the newest version.libdbi-perl is already the newest version.libemail-valid-perl is already the newest version.libfile-copy-recursive-perl is already the newest version.libfile-homedir-perl is already the newest version.libhash-merge-perl is already the newest version.libjson-perl is already the newest version.libmailtools-perl is already the newest version.libmime-tools-perl is already the newest version.libnet-dns-perl is already the newest version.libnet-libidn-perl is already the newest version.libsort-naturally-perl is already the newest version.libtimedate-perl is already the newest version.libunix-mknod-perl is already the newest version.libwww-perl is already the newest version.libxml-parser-perl is already the newest version.libxml-simple-perl is already the newest version.lzma is already the newest version.make is already the newest version.mawk is already the newest version.ssh is already the newest version.openssl is already the newest version.patch is already the newest version.pbuilder is already the newest version.pbzip2 is already the newest version.perl is already the newest version.pigz is already the newest version.postfix is already the newest version.proftpd-basic is already the newest version.proftpd-mod-mysql is already the newest version.resolvconf is already the newest version.sudo is already the newest version.tar is already the newest version.apache2 is already the newest version.apache2-bin is already the newest version.apache2-data is already the newest version.apache2-dev is already the newest version.apache2-suexec-pristine is already the newest version.git is already the newest version.libmysqlclient18 is already the newest version.libmysqlclient20 is already the newest version.mysql-common is already the newest version.mysql-community-client is already the newest version.mysql-community-server is already the newest version.libapache2-mod-php5.6 is already the newest version.php-apcu is already the newest version.php-pear is already the newest version.php5.6 is already the newest version.php5.6-cgi is already the newest version.php5.6-cli is already the newest version.php5.6-common is already the newest version.php5.6-curl is already the newest version.php5.6-fpm is already the newest version.php5.6-gd is already the newest version.php5.6-imap is already the newest version.php5.6-intl is already the newest version.php5.6-json is already the newest version.php5.6-mbstring is already the newest version.php5.6-mcrypt is already the newest version.php5.6-mysql is already the newest version.php5.6-opcache is already the newest version.php5.6-pspell is already the newest version.php5.6-xml is already the newest version.php5.6-zip is already the newest version.bash-completion is already the newest version.ifupdown is already the newest version.locales-all is already the newest version.libc6-dev is already the newest version.Some packages could not be installed. This may mean that you haverequested an impossible situation or if you are using the unstabledistribution that some required packages have not yet been createdor been moved out of Incoming.The following information may help to resolve the situation:The following packages have unmet dependencies: libssl-dev : Depends: libssl1.0.0 (= 1.0.1t-1+deb8u6) but 1.0.2l-1~bpo8+1 is to be installedE: Unable to correct problems, you have held broken packages.[ERROR] autoinstaller::Functions::build: An error occurred while performing build steps


    my sorcelist






    my system



    PHP 5.6.31-4+0~20170804100521.6+jessie~1.gbpea630b (cli)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies



    Debian 9


    Server version: Apache/2.4.10 (Debian)
    Server built: Jul 18 2017 18:32:16


    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 110179
    Server version: 5.7.19 MySQL Community Server (GPL)




    imscp 1.4.7

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • Debian 9

    Are you sure? If you are using Jessie, this should be 8 ;)


    Result of lsb_release -a?


    Did you upgraded your system before running the installer: apt-get update && apt-get dist-upgrade?


    Also please

    • Result of apt-cache policy libssl-dev?
    • Result of apt-cache policy libssl1.0.0?

    The following packages have unmet dependencies:
    libssl-dev : Depends: libssl1.0.0 (= 1.0.1t-1+deb8u6) but 1.0.2l-1~bpo8+1 is to be installed
    E: Unable to correct problems, you have held broken packages.

    1.0.2l-1~bpo8+1 means package from backports repository. However, I don't see the backports repository listed in your sources.list. Content of your /etc/apt/sources.list.d directory?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206


  • Code
    1. root@ns367176:/usr/local/src/imscp-1.5.1# lsb_release -aNo LSB modules are available.Distributor ID: DebianDescription: Debian GNU/Linux 8.9 (jessie)Release: 8Codename: jessieroot@ns367176:/usr/local/src/imscp-1.5.1#






    Code
    1. root@ns367176:/usr/local/src/imscp-1.5.1# apt-cache policy libssl1.0.0libssl1.0.0: Installiert: 1.0.2l-1~bpo8+1 Installationskandidat: 1.0.2l-1~bpo8+1 Paket-Pinning: 1.0.2l-1~bpo8+1 Versionstabelle: *** 1.0.2l-1~bpo8+1 600 100 http://deb.debian.org/debian/ jessie-backports/main amd64 Packages 100 /var/lib/dpkg/status 1.0.1t-1+deb8u6 600 500 http://ftp.de.debian.org/debian/ jessie/main amd64 Packages 500 http://security.debian.org/ jessie/updates/main amd64 Packagesroot@ns367176:/usr/local/src/imscp-1.5.1#




    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • comically was not present the backports repository has it added and now installed on the other 'I need now is again.

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)

  • You have the debian-jessie backports repository (surely added by mailman plugin)
    I also see a stretch repository (surely added by mailman plugin)


    Please for the update time, remove the /etc/apt/preferences.d/imscp_mailman_plugin file if any and once done, retry.
    I'll review the pinning for next release.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • @Speedy


    Solved ?

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • yes

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)