CronJobs plugin: iMSCP::Mount::mount: Error while executing mount

  • Shell-Script
    1. [ERROR] iMSCP::Mount::mount: Error while executing mount(devpts, /var/chroot/CronJobs/jail/dev/pts, devpts, 3236757504, newinstance,gid=5,mode=620,ptmxmode=0666): Datei oder Verzeichnis nicht gefunden
    2. [ERROR] autoinstaller::Functions::install: An error occurred while performing installation steps

    my system



    PHP 5.6.30-8+0~20170315222803.29+jessie~1.gbp29ec6b (cli)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies


    Server version: Apache/2.4.25 (Debian)
    Server built: 2017-01-25T14:56:13



    Server version: 5.7.17 MySQL Community Server (GPL)



    Imscp 1.4.0

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)


    https://www.4sync.com/web/r/dwMJ2VT4

  • @Speedy

    • Result of ls -la /var/chroot/CronJobs/jail command?
    • Result of mount command?

    The problem comes from the CronJobs plugin.


    Thread moved.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • ls -la /var/chroot/CronJobs/jail

    Shell-Script
    1. root@ns367176:~# ls -la /var/chroot/CronJobs/jaills: Zugriff auf /var/chroot/CronJobs/jail nicht möglich: Datei oder Verzeichnis nicht gefundenroot@ns367176:~#




    Result of mount command?




    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)


    https://www.4sync.com/web/r/dwMJ2VT4

  • @Speddy


    Obiously, the jail is not here and thus, the mount command fails. You should disable the plugin manually:


    SQL
    1. # mysql
    2. > use imscp;
    3. > UPDATE plugin SET plugin_status = 'disabled' WHERE plugin_name = 'CronJobs';
    4. > \q

    Once done, rerun the installer. You'll have to re-enable the plugin later on ;)

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Once done, rerun the installer.

    Congratulations │
    │ │
    │ i-MSCP has been successfully installed/updated.

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)


    https://www.4sync.com/web/r/dwMJ2VT4

  • @Speedy


    Great ;) I'll investigate soon about this issue. If the jail is missing, the mount command shouldn't occurs.


    Thank for your report.

    badge.php?id=1239063037&bid=2518&key=1747635596&format=png&z=547451206

  • Great I'll investigate soon about this issue. If the jail is missing, the mount command shouldn't occurs.

    Can it be because I am currently not registered cron?

    my System :



    - Distribution: Debian | Release: 9.8 | Codename: wheezy
    - i-MSCP Version: i-MSCP 1.5.3| Build: 20181208 | Codename: Ennio Morricone
    - Plugins installed: ClamAV (v. 1.2.1), Mailgraph (v 1.1.1), OpenDKIM (v 1.1.3), PanelRedirect (v 1.1.5) & SpamAssassin (v 1.1.1)
    - LetsEncrypt (v3.3.0), PhpSwitcher (v 4.0.1), RoundcubePlugins (v 2.0.1)


    https://www.4sync.com/web/r/dwMJ2VT4