Can't create or modify FTP-User for Domain

  • After restoring the whole ismcp-system in cause of a system crash, I noticed a weird behavior on my domain ftp-users.

    No existing user can connect through a ftp-client (Login incorrect). Additionally, I have no possibility to modify ftp-users password or home directory. I always get an alert "directory xyz does not exist". By clicking the button to choose a new ftp home directory I'm getting an alert like "Request failed" (400).

    Is there a permission issue in my restored files?

    In case of any other issue: How can I solve it?

    Edited 3 times, last by calli2310 ().

  • Hello,

    First please, read Reporting rules - Reminder and add the missing info.


  • Thanks for your advice =)

    Implementation: fcgid
    i-mscp-Version: 1.3.0

    Syslog throws the following:

    Aug 21 16:43:17 v12941 proftpd[20849]: [myIP] ([]) - FTP session opened.
    Aug 21 16:43:17 v12941 proftpd[20849]: [myIP] ([]) - [myFTPUser] chdir("/") failed: Keine Berechtigung
    Aug 21 16:43:17 v12941 proftpd[20849]: [myIP] ([]) - FTP session closed.

    Obviously permission issue. I'm trying to find out, how to solve it, at the moment.

    Creating new ftp-users is possible again, but only with "/" as home directory. Login still doesn't work, too.


    I solved it!

    I checked /etc/passwd and saw the following users:

    i-mscp master web user with gid="1001" und uid="1001"
    i-mscp web user with gid="1002" and uid="1002"

    imscp database contains "admin" table with my domain-user that has "1001" in columns "admin_sys_gid" and "admin_sys_uid". I compared these fields with one from another new i-mscp installation on a separate test-host and noticed a difference.

    I updated the values of both columns to "1002". Additionally I updated column "gid" in table "ftp_group" and columns "uid", "gid" in columns "ftp_users" for all entries.

    After that, everything works fine again.

    I hope, someone with the same problem can find this thread and saves a lot of time.

    Edited 4 times, last by calli2310 ().