Awstats cron task doesn't seem to work

  • Hello,

    I've just noticed after upgrading to the latest stable my awstats is not working. Any ideas how I can troubleshoot it?
    Stats remains at 0 since the update.

    Thank you in advance.

  • Hello ;

    Did you fixed the vlogger problem manually as described here: [1.2.2] Apache access Log in /etc/apache2 after update

    If not done, do it ;)


  • Thank you for your reply.
    This has already been done unfortunately and the problem still persists.

  • Well, what is the problem exactly? You do not see any change in the Awstats interface?

    What if you run the following command manually (provide me the output please) ?

    1. # /usr/bin/perl /var/www/imscp/engine/PerlLib/Package/Webstats/Awstats/Scripts/ now -awstatsprog=/usr/lib/cgi-bin/


  • The figures do not update and visits remain at 0.
    When I run the command, the figures are updated :

    In fact it seems that this is no longer done automatically.

  • What is the content of your /etc/cron.d/imscp ? Post the content here please.


  • I don't see anything wrong there.

    Cron job for Awstats should be run at

    1. 3:15
    2. 9:15
    3. 15:15
    4. 21:15

    I'll process some tests to be sure.

    BTW: Title of the thread edited. Next time, choose a better title for your threads.


  • Okay, thank you.
    Excuse me for the title.
    When I run the command manually it puts the statistics days, but
    if anything is updated automatically.

  • My problem was the same.

    One of my customer alert me today about stats not working.

    As it is on the screenshot too, the stats stopped at 22.02.2015.

    As i remember i updated the imscp on this day to version 1.2.2

    This topic was very helpful to fix the problem: [1.2.2] Apache access Log in /etc/apache2 after update

    I dont know if the imscp update was the problem cause or not, but now stats working properly.