PHP5-FPM - Reload on Ubuntu 14.04 (Trusty)

  • Hi,

    on my i-MSCP machine with Ubuntu 14.04 i've found a problem

    The problem i think is related to the restart / reload function implemented by the PHP5-FPM service

    When i modify the disable_functions in i-MSCP client or admin panel and apply, apache return error 500. In command line appears that not all php-fpm are stopped correctly and a php5-fpm restart / stop / reload get the "unknow instance" error. I must to kill all the related PID and start php5-fpm

    Here the launchpad bug

    Thank you very much

  • Hello ;

    This issue has been already addressed in last i-MSCP version. You must simply not start/reload php5-fpm using the init script (/etc/init.d/php5-fpm). Instead you must use the service command (service php5-fpm ...).

    Ubuntu had a good idea to introduce upstart... See the result now ;)


  • Hi,

    hmmm.. I'm not sure because I do not remember well, but it's from Ubuntu 10.04 that I use "service service_name action" to perform operations on services, so I think that the first command I gave was that, but it had not restart correctly..

    Could be fixed in i-MSCP command or not? Should I upgrade my version from GitHub?


  • Re;

    Try to upgrade to last stable branch and run the installer as follow:

    1. # perl imscp-autoinstall -df


  • Hi,

    no, i've tried but no results... enabled/disabled some disabled_functions and when apply it does not work

    Also through command line:

    service php5-fpm restart
    stop: Unknown instance:
    php5-fpm start/running, process 8440
    service php5-fpm stop
    stop: Unknown instance:

    Also, my i-MSCP version have not changed version.. it's the same as on my signature

  • @sport80

    If I've asked you to upgrade to last Stable branch, it's not for nothing.

    So again try this:

    Kill any php-fpm process manually

    1. # pkill -KILL -f php-fpm

    Download last available state of the stable branch from github and unpack it:

    1. # cd /usr/local/src# wget unzip

    Upgrade your i-MSCP system by running the following command:

    1. # perl imscp-autoinstall -daf

    Options here means:
    -d : Force debug mode
    -a: No not reload addon packages from github
    -f: Force reinstallation of distro packages


  • Ok, i've tried as you have described

    same results.. same i-MSCP version... same problems..

    the system is apt-get updated and upgraded

    before i have used a i-mscp script to update to the last version that use

    git clone -b stable git:// /usr/local/src/stable/imscp

  • Teamviewer possible?


  • Ok, nuxwin have solved this problem.

    This is a bug in the upstart init script in ubuntu package

    To solve easy you must to modify the /etc/init/php5-fpm.conf and edit

    #reload signal USR2


    reload signal USR2

    Thank you very much