Host your own SeaFile cloud (with ssl support)

  • Thanks for your response.
    I tried both versions before and got the same error.

    Thank you for the information, I know it would be better with the sym link to the latest version but when I use it I got another error so the version with direct linking is working without one;-)

    Yep I saw it but as I use Apache 2.2 I couldn´t use the new apache modules (introduced with 2.4) which they call in their new documentation.

    It´s till strange why the server changes to non https...

  • The seafile manual says if you are using FastCgi every request is made throught apache (and apache calls seafile using the FastCgi implementation).

    Please verify, that you enabled FastCgi and start seahub with the parameter "start-fastcgi". For this please check steps 4,5 and 6 again.

    If every step is as described and FastCgi is enabled you have to contact the seafile support team or take a look into the manual (and if it is a bug or if you have any solution feel free to tell me - I am going to include it into this how to post). For me on Ubuntu 14.04 LTS it is working great.

  • Hi,

    right this is what I understanded. The module is activated and the corresponding line is added in apache2.conf.
    I will contact seafile support team.

    Just a quick question. Which version of apache are you using as it is working for you?

    Edited once, last by BratHuhn ().

  • Okay found the solution.

    Since seafile managed to edit some settings in the seahub webinterface I had to edit them there and not in the conf-files.

    Adding the missing https @FILE_SERVER_ROOT in the webinterface settings brings the fix!