Postfix - How to disable HELO checks

  • Hello everybody

    i am getting the following error when I am trying to receive an eMail.


    550 5.7.1 Recipient address rejected: Mail appeared to be SPAM or forged. Ask you Mail / DNS Administrator to correct HELO and DNS MX settings or to get removed from DNSBLs: Please relay via you ISP Error timeout exceeded.

    I think the HELO adress is not correct or blocked.
    Is there a HELO checking for Domains? How can I deactive HELO checking?

    I found out that there is a Greylisting too. Is there any possibility how i can check all AntiSpam Options of imscp or am I complete wrong and the error message shown above is something else?

    Many thanks!!

    Edited once, last by Nuxwin ().

  • Hello ;

    I. HELO checks

    In the /etc/postfix/ file (smtpd_helo_restrictions), you can try to remove these smtp restrictions:

    1. reject_invalid_helo_hostnameandreject_non_fqdn_helo_hostname

    But, also, in the /etc/postfix/ file: (smtpd_recipient_restrictions), you can try to disable the policyd service (not recommended):

    1. check_policy_service inet:

    This is not recommended because it's more safe to disable the HELO check on domains only, which is made by the policyd service. if you are using last master, you can do that by re-configuring the mailfilters service using the i-MSCP setup script:

    1. # cd /var/www/imscp/engine/setup# perl imscp-setup --debug --reconfigure mailfilters

    To give you more information about how to process for any other i-MSCP version, we must know the i-MSCP version you are using.


    If you want really disable the Postgrey service, you must remove the following line in the /etc/postfix/ file:

    1. check_policy_service inet:{PORT_POSTGREY},

    where the {PORT_POSTGREY} placeholder is the postgrey port

    and stop the service by doing:

    1. service postgrey stop

    Note: Do not forget to restart the Postfix service too.

    Thanks you for using i-MSCP.


    Edited once, last by Nuxwin ().