Php Switcher | Add php 7.2 on Debian 10

  • Hi everyone!

    Hop ethis message finds you well :)

    I am working on Debian 10 (buster) with i-MSCP 1.5.3 2018120800 and I have that issue to install php7.2.

    Could you help me?



  • Seeing this :


    Removing imscp-psw-php7.2-build-deps:amd64 because I can't find libpcre2-dev:amd64

    I would guess, try to install it first (even if this shouldn't be necessary)

    Also, I see that :


    Ign:X stretch/main all Packages

    Still refering to stretch release (9), so look into your apt directory for the php repository, you might have miss that one there.

    So for me, the second one will be my first fix to try, then redo the same deploy command as earlier.

    Edited once, last by Athar ().

  • Hi Athar,

    Thanks for your answer.

    Sources list in /etc/apt/sources.list is with buster upgrades. That is why I don't understand why phpswitcher is using stretch sources...

    Is it the right repository that I need to update?


  • Should only be located in sources.list file (for PHP, using Sury repos).

    Could be some plugin cache issue.

    Maybe try to remove the plugin and reinstall it.

    Check also that you have the latest version of the plugin too (which is 5.0.5).

    I'm on Buster, no issue on my side.

  • Thanks Athar for helping me!

    Nevertheless, Sury repos are still in sources.list file.

    What's more, I tried to remove and reinstall the plugin phpswitcher but the plugin is still using stretch distribution... I don't know why!

    One detail: I upgraded Debian 9 to Debian 10.

    Edited once, last by wepicurien ().

  • In case someone else got the same behavior :

    Pre-requisite wasn't met : Missing dependencies for packaged setup (as not met, it revert to compile mode).

    In this case, for PHP7.2, this was needed :

    1. apt-get install php7.2-cli php7.2-cgi php7.2-fpm php-pear

    After that, rerun of PhpSwitcher command to register PHP7.2 worked.

    This is specified in the Wiki : Wiki page